poj1971 平行四边形个数

There are n distinct points in the plane, given by their integer coordinates. Find the number of parallelograms whose vertices lie on these points. In other words, find the number of 4-element subsets of these points that can be written as {A, B, C, D} such that AB || CD, and BC || AD. No four points are in a straight line.
Input
The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases. It is followed by the input data for each test case.
The first line of each test case contains an integer n (1 <= n <= 1000). Each of the next n lines, contains 2 space-separated integers x and y (the coordinates of a point) with magnitude (absolute value) of no more than 1000000000.
Output
Output should contain t lines.
Line i contains an integer showing the number of the parallelograms as described above for test case i.
Sample Input
2
6
0 0
2 0
4 0
1 1
3 1
5 1
7
-2 -1
8 9
5 7
1 1
4 8
2 0
9 8
Sample Output
5
6

思路:计算平行四边形数目,则求出中点相同的个数,公式2分之n乘n-1
中点相同等价于x与y和相同所以不用除以2。

#include<iostream>
#include<cstdio>
#include<algorithm>
#include <cstring>
using namespace std;
struct lkq
{
    int x;
    int y;
}p[1005];
struct lkq s[1005*1005];
struct lkq mind(struct lkq a,struct lkq b)
{
    struct lkq mind;
    mind.x=(a.x+b.x);
    mind.y=(a.y+b.y);
    return mind;
}
bool cmp(struct lkq a,struct lkq b)
{
    if(a.x==b.x)
        return a.y<b.y;
    return a.x<b.x;
}
int main()
{
    int T,n;
    cin>>T;
    while(T--)
    {
        int c=0,ans=1;
        scanf("%d",&n);
        for(int i=0;i<n;i++)
            scanf("%d%d",&p[i].x,&p[i].y);
        for(int i=0;i<n-1;i++)
        {
            for(int j=i+1;j<n;j++)
            {
                s[c++]=mind(p[i],p[j]);
            }
        }
        sort(s,s+c,cmp);
        int sum=0;
        for(int i=0;i<c-1;i++)
        {
            if(s[i].x==s[i+1].x&&s[i].y==s[i+1].y)
                ans++;
            else
            {
                sum+=(ans-1)*ans/2;
                ans=1;
            }
        }
        printf("%d\n",sum);
    }
    return 0;
}

注:
1.结构体数组 struct lkq s[ ];
2.定义struct lkq sum计算和
3.贪心排序 如果x相同,y小的返回
bool cmp(struct lkq a,struct lkq b)

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值