0.7poj2231(排序记公式)

http://poj.org/problem?id=2231

Moo Volume
Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 16612Accepted: 4827

Description

Farmer John has received a noise complaint from his neighbor, Farmer Bob, stating that his cows are making too much noise.

FJ's N cows (1 <= N <= 10,000) all graze at various locations on a long one-dimensional pasture. The cows are very chatty animals. Every pair of cows simultaneously carries on a conversation (so every cow is simultaneously MOOing at all of the N-1 other cows). When cow i MOOs at cow j, the volume of this MOO must be equal to the distance between i and j, in order for j to be able to hear the MOO at all. Please help FJ compute the total volume of sound being generated by all N*(N-1) simultaneous MOOing sessions.

Input

* Line 1: N

* Lines 2..N+1: The location of each cow (in the range 0..1,000,000,000).

Output

There are five cows at locations 1, 5, 3, 2, and 4.

Sample Input

5
1
5
3
2
4

Sample Output

40

Hint

INPUT DETAILS:

There are five cows at locations 1, 5, 3, 2, and 4.

OUTPUT DETAILS:

Cow at 1 contributes 1+2+3+4=10, cow at 5 contributes 4+3+2+1=10, cow at 3 contributes 2+1+1+2=6, cow at 2 contributes 1+1+2+3=7, and cow at 4 contributes 3+2+1+1=7. The total volume is (10+10+6+7+7) = 40.

Source

题意:求求直线上所有两点间距离之和。直接暴力两个for10000*10000必然超时。不过网上有人这么做却不会超时就是for(i=0;i<n;i++)
              for(j=i+1;j<n;j++)
                          sum+=abs(a[j]-a[i]);

更好的方法网上推导:假设从第M个有F(M)个线段 则第M +1 有F(M + 1) = F(M + 1)
+ M + M - 1 + M - 2 + ... + 1;
(只考虑单向)意思就是一个线段比如N取6, 第1到2有5条线(即经过5次
),2到3有4次,3到4 3次,4到5 2次, 5到6 1次。这时若再加一个点,
则加上 6 + 5 + 4 + 3 + 2 + 1 。则假设还是6个点。第1到2经历5次,
2到3经历4 + 4次, 3到4经历3 + 3 + 3次,4到5经历 2 + 2 + 2 + 2
次 5到6次 1 + 1 + 1 + 1 + 1,结果即出来了。。。通项公式即
(a[i] - a[i - 1]) * (N - i) * i

#include<cstdio>
#include<algorithm>
#include<iostream>
#define MAXN 10005
long long  a[MAXN];
long long  sum;
int cmp(const void*a,const void*b)//小到大排序
{
  return (*(int*)a-*(int*)b);
}
int main()
{
  int n;
  while(scanf("%d",&n)!=EOF)
  {
    int i;
    for(i=0;i<n;i++)
      scanf("%lld",&a[i]);
    qsort(a,n,sizeof(a[0]),cmp);
    sum=0;
    for(i=0;i<n-1;i++)
    {
      sum+=(a[i+1]-a[i])*(n-i-1)*(i+1);
    }
    printf("%lld\n",sum*2);
  }
  return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值