poj1323(贪心)

http://poj.org/problem?id=1323

Game Prediction
Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 8292Accepted: 3976

Description

Suppose there are M people, including you, playing a special card game. At the beginning, each player receives N cards. The pip of a card is a positive integer which is at most N*M. And there are no two cards with the same pip. During a round, each player chooses one card to compare with others. The player whose card with the biggest pip wins the round, and then the next round begins. After N rounds, when all the cards of each player have been chosen, the player who has won the most rounds is the winner of the game.



Given your cards received at the beginning, write a program to tell the maximal number of rounds that you may at least win during the whole game.

Input

The input consists of several test cases. The first line of each case contains two integers m (2?20) and n (1?50), representing the number of players and the number of cards each player receives at the beginning of the game, respectively. This followed by a line with n positive integers, representing the pips of cards you received at the beginning. Then a blank line follows to separate the cases.

The input is terminated by a line with two zeros.

Output

For each test case, output a line consisting of the test case number followed by the number of rounds you will at least win during the game.

Sample Input

2 5
1 7 2 10 9

6 11
62 63 54 66 65 61 57 56 50 53 48

0 0

Sample Output

Case 1: 2
Case 2: 4

Source

题意:这题真的理解了很久啊一直不理解。At the beginning, each player receives N cards. The pip of a card is a positive integer which is at most N*M. And there are no two cards with the same pip.
这句是关键就是每个人有N张卡片,且每个人的卡片都不一样。(刚开始一直理解成这些卡片是相同的)嗨,理解的太偏。这些牌的序号是从1——N*M的
题意:n个人在玩牌,每个人有m张牌,于是就有n*m张牌(每张牌都有一个值,介于1到n*m之间,不重复),然后进行m轮游戏,每轮每个人都出一张牌,牌最大的那个人就赢了,然后给出n和m,以及你的m张牌,问你最多能赢几轮?
思路:将除了你自己手中牌的数字的其他最大的m个数字的牌给予另一个人,即给予该人一副最优的牌,接下来就是判断你和这个人玩这个游戏,你至少能获胜几轮。
太谢谢了。。。
网上还有一种很普遍的做法,但是我还有个点不理解。。
discuss里面有一种和我想的差不多。。也就是和最上面的那位其实差不多http://poj.org/showmessage?message_id=148827
 
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
int me[60],other[60];
int used[10050];
int n,m;
int Case=0,ans;
int cmp(const void *a,const void *b)
{
     return *(int *)a - *(int *)b;
}
int main()
{
 int i,j;
 while(scanf("%d%d",&n,&m) && n!=0 )
 {
  ans=0;
  Case++;
  memset(used,0,sizeof(used));
        for(i=0;i<m;i++)
  {
   scanf("%d",&me[i]);
   used[me[i]]=1;
  }
  for(i=n*m,j=0;j<m;i--)//给予某个人一副最优的牌
  {
   if(!used[i])
   {
                  other[j]=i;
      used[other[j]]=1;
      j++;
   }
  }
        qsort(me,m,sizeof(me[0]),cmp);
  qsort(other,m,sizeof(other[0]),cmp);
  for(i=m-1;i>=0;i--)//你从大出道小,而另一个人只需要出他手中的比你大的牌中的最小的一张,即该轮你是输的
  {
             for(j=0;j<m;j++)
    {
     if(other[j]>me[i] && used[other[j]])
     {
      used[other[j]]=0;
      break;
     }
    }
  }
  for(i=0;i<m;i++)//判断那一个人输的次数,也就是你赢的次数
   if(used[other[i]])
    ans++;
   printf("Case %d: %d\n",Case,ans);
 }
 return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值