1135 Is It A Red-Black Tree

There is a kind of balanced binary search tree named red-black tree in the data structure. It has the following 5 properties:

  • (1) Every node is either red or black.
  • (2) The root is black.
  • (3) Every leaf (NULL) is black.
  • (4) If a node is red, then both its children are black.
  • (5) For each node, all simple paths from the node to descendant leaves contain the same number of black nodes.

For example, the tree in Figure 1 is a red-black tree, while the ones in Figure 2 and 3 are not.

rbf1.jpgrbf2.jpgrbf3.jpg
Figure 1Figure 2Figure 3

For each given binary search tree, you are supposed to tell if it is a legal red-black tree.

Input Specification:

Each input file contains several test cases. The first line gives a positive integer K (≤30) which is the total number of cases. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the preorder traversal sequence of the tree. While all the keys in a tree are positive integers, we use negative signs to represent red nodes. All the numbers in a line are separated by a space. The sample input cases correspond to the trees shown in Figure 1, 2 and 3.

Output Specification:

For each test case, print in a line "Yes" if the given tree is a red-black tree, or "No" if not.

Sample Input:

3
9
7 -2 1 5 -4 -11 8 14 -15
9
11 -2 1 -7 5 -4 8 14 -15
8
10 -7 5 -6 8 15 -11 17

Sample Output:

Yes
No
No

 

#include<iostream>
#include<string>
#include <algorithm>
#include <bits/stdc++.h>
#define INF 999999
#define ll long long
using namespace std;
int n,k;
struct node{
    int v;
    node* right;
    node* left;
};
vector<int>arr;
void build(node* &root,int val){
    if(root==NULL){
        root = new node();
        root->left=root->right=NULL;
        root->v=val;
    }
    else if(abs(val)<abs(root->v))build(root->left, val);
    else build(root->right, val);
}
bool judge1(node* root){
    if(root==NULL)return true;
    if(root->v<0){
        if(root->left!=NULL&&root->left->v<0)return false;
        if(root->right!=NULL&&root->right->v<0)return false;
    }
    return judge1(root->left)&&judge1(root->right);
}

int getDeep(node* root){
    if(root==NULL)return 0;
    int l = getDeep(root->left);
    int r = getDeep(root->right);
    return root->v>0?max(l, r)+1:max(l,r);
}
bool judge2(node* root){
    if(root==NULL)return true;
    int l = getDeep(root->left);
    int r = getDeep(root->right);
    if(r!=l)return false;
    return judge2(root->left)&&judge2(root->right);
}


int main(){
    scanf("%d",&n);
    for(int i=0;i<n;i++){
        node* root = NULL;
        scanf("%d",&k);
        arr.resize(k);
        for(int j=0;j<k;j++){
            scanf("%d",&arr[j]);
            build(root, arr[j]);
        }
        if (arr[0] < 0 || judge1(root) == false || judge2(root) == false)
            printf("No\n");
        else
            printf("Yes\n");
    }
    
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值