1135 Is It A Red-Black Tree (30 分)

There is a kind of balanced binary search tree named red-black tree in the data structure. It has the following 5 properties:

(1) Every node is either red or black.
(2) The root is black.
(3) Every leaf (NULL) is black.
(4) If a node is red, then both its children are black.
(5) For each node, all simple paths from the node to descendant leaves contain the same number of black nodes.
For example, the tree in Figure 1 is a red-black tree, while the ones in Figure 2 and 3 are not.

rbf1.jpg rbf2.jpg rbf3.jpg
Figure 1 Figure 2 Figure 3
For each given binary search tree, you are supposed to tell if it is a legal red-black tree.

Input Specification:
Each input file contains several test cases. The first line gives a positive integer K (≤30) which is the total number of cases. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the preorder traversal sequence of the tree. While all the keys in a tree are positive integers, we use negative signs to represent red nodes. All the numbers in a line are separated by a space. The sample input cases correspond to the trees shown in Figure 1, 2 and 3.

Output Specification:
For each test case, print in a line “Yes” if the given tree is a red-black tree, or “No” if not.

Sample Input:
3
9
7 -2 1 5 -4 -11 8 14 -15
9
11 -2 1 -7 5 -4 8 14 -15
8
10 -7 5 -6 8 15 -11 17
Sample Output:
Yes
No
No

不知道它这个红黑树跟真正的红黑树定义是不是一样的,但红黑树本身也是二叉搜索树,所以可以用二叉搜索树的插入方式进行建树。

只需要判断三个地方:
1.根是否大于0;
2.节点为红,两个孩子必须是黑(黑色的没有要求)
3.所有根节点到叶子的路径上黑色节点的个数是不是均相等

#include<bits/stdc++.h>
using namespace std;
struct TreeNode {
	int val;
	TreeNode* left, * right;
	TreeNode(int x) :val(x), left(NULL), right(NULL) {}
};
void insert(TreeNode*& root, int x) {
	if (!root)
		root = new TreeNode(x);
	else insert(abs(x) < abs(root->val) ? root->left : root->right, x);
}
bool dfs(TreeNode* root, map<int, int>& num, int path) {
	if (!root) {
		num[path]++;
		return num.size() == 1;
	}
	path += root->val > 0 ? 1 : 0;
	if (root->val < 0 && ((root->left ? root->left->val : 1) < 0 || (root->right ? root->right->val : 1) < 0))
		return false;
	return dfs(root->left, num, path) && dfs(root->right, num, path);
}
int main()
{
	int n, m, a;
	cin >> n;
	for (int i = 0; i < n; i++) {
		cin >> m;
		TreeNode* root = NULL;
		map<int, int>num;
		for (int j = 0; j < m; j++) {
			cin >> a;
			insert(root, a);
		}
		cout << ((dfs(root, num, 0) && root->val > 0) ? "Yes" : "No") << endl;
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值