1135 Is It A Red-Black Tree(30 分)

There is a kind of balanced binary search tree named red-black tree in the data structure. It has the following 5 properties:

  • (1) Every node is either red or black.
  • (2) The root is black.
  • (3) Every leaf (NULL) is black.
  • (4) If a node is red, then both its children are black.
  • (5) For each node, all simple paths from the node to descendant leaves contain the same number of black nodes.

For example, the tree in Figure 1 is a red-black tree, while the ones in Figure 2 and 3 are not.

rbf1.jpgrbf2.jpgrbf3.jpg
Figure 1Figure 2Figure 3

For each given binary search tree, you are supposed to tell if it is a legal red-black tree.

Input Specification:

Each input file contains several test cases. The first line gives a positive integer K (≤30) which is the total number of cases. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the preorder traversal sequence of the tree. While all the keys in a tree are positive integers, we use negative signs to represent red nodes. All the numbers in a line are separated by a space. The sample input cases correspond to the trees shown in Figure 1, 2 and 3.

Output Specification:

For each test case, print in a line "Yes" if the given tree is a red-black tree, or "No" if not.

Sample Input:

3
9
7 -2 1 5 -4 -11 8 14 -15
9
11 -2 1 -7 5 -4 8 14 -15
8
10 -7 5 -6 8 15 -11 17

Sample Output:

Yes
No
No

思路:

给一个树的前序遍历,判断它是否为红黑树,是输出Yes,否则输出No。

1.是否是二叉搜索树 
2.根结点是否为黑色 
3.如果一个结点是红色,它的孩子节点是否都为黑色 
4.从任意结点到叶子结点的路径中,黑色结点的个数是否相同

C++:

#include "iostream"
#include "queue"
using namespace std;
struct node
{
	int val;
	struct node *lchild,*rchild;
};
//建树
void build(node* &root,int v){
	if (root==NULL)
	{
		root=new node();
		root->lchild=root->rchild=NULL;
		root->val=v;
		return;
	}else if(abs(v)<=abs(root->val))
		build(root->lchild,v);
	else
		build(root->rchild,v);
}
//temp记录黑的个数
void DFS(node* root,int temp,int &black)
{
	//叶节点
	if(root==NULL)
	{
		if(black==-1)black=temp;
		else if(black!=temp)black=-2;
		return;
	}
	if(black==-2)return;
	if(root->val>0)temp++;
	DFS(root->lchild,temp,black);
	DFS(root->rchild,temp,black);
}
bool BFS(node* root){
	queue<node*> q;
	q.push(root);
	if(root->val<0)return false;//根结点是红
	while(!q.empty())
	{
		node* top=q.front();
		q.pop();
		int black=-1;
		DFS(top,0,black);
		if(black==-2)return false;
		if(top->lchild!=NULL)
		{
			if(top->val<0&&top->lchild->val<0)return false;
			else q.push(top->lchild);
		}
		if(top->rchild!=NULL)
		{
			if(top->val<0&&top->rchild->val<0)return false;
			else q.push(top->rchild);
		}
	}
	return true;
}


int main(){
	int k,n,v;
	scanf("%d",&k);
	for(int i=0;i<k;i++)
	{
		scanf("%d",&n);
		node *root=NULL;
		for(int j=0;j<n;j++)
		{
			scanf("%d",&v);
			build(root,v);
		}
		if(BFS(root)==true)printf("Yes\n");
		else printf("No\n");
	}
	return 0;

}

 

  • 0
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值