1010 Radix (25 分)
Given a pair of positive integers, for example, 6 and 110, can this equation 6 = 110 be true? The answer is yes
, if 6 is a decimal number and 110 is a binary number.
Now for any pair of positive integers N1 and N2, your task is to find the radix of one number while that of the other is given.
Input Specification:
Each input file contains one test case. Each case occupies a line which contains 4 positive integers:
N1 N2 tag radix
Here N1
and N2
each has no more than 10 digits. A digit is less than its radix and is chosen from the set { 0-9, a
-z
} where 0-9 represent the decimal numbers 0-9, and a
-z
represent the decimal numbers 10-35. The last number radix
is the radix of N1
if tag
is 1, or of N2
if tag
is 2.
Output Specification:
For each test case, print in one line the radix of the other number so that the equation N1
= N2
is true. If the equation is impossible, print Impossible
. If the solution is not unique, output the smallest possible radix.
Sample Input 1:
6 110 1 10
Sample Output 1:
2
Sample Input 2:
1 ab 1 2
Sample Output 2:
Impossible
#include<iostream>
#include<stack>
#include<string>
#include<vector>
#include<map>
#include <cmath>
#include<algorithm>
using namespace std;
long long translate(string s,long long radix) {
long long sum=0;
for (long long i = 0; i< s.size(); i++)
sum = sum*radix+ ((s[i]-'a'<0) ? (s[i] - '0') : s[i] - 'a' + 10);
return sum;
}
int main() {
string a, b;
long long tag, radix,n,r=-1;
cin >> a >> b >> tag >> radix;
if (tag == 2)swap(a, b);
char it = *max_element(b.begin(), b.end());
long long low = ((it - 'a'<0) ? (it - '0') : it - 'a' + 10)+1;
n = translate(a, radix);
long long high = max(low, n);
while (high>=low) {
long long mid = (high + low) / 2;
long long temp = translate(b, mid);
if (temp == n) {
r = mid;
break;
}
else if (temp<0 || temp>n)
high = mid - 1;
else
low = mid + 1;
}
if (r == -1)
cout << "Impossible";
else
cout << r;
return 0;
}