HDU4081Qin Shi Huang's National Road System kruscal次小生成树

http://acm.hdu.edu.cn/showproblem.php?pid=4081

Problem Description

During the Warring States Period of ancient China(476 BC to 221 BC), there were seven kingdoms in China ---- they were Qi, Chu, Yan, Han, Zhao, Wei and Qin. Ying Zheng was the king of the kingdom Qin. Through 9 years of wars, he finally conquered all six other kingdoms and became the first emperor of a unified China in 221 BC. That was Qin dynasty ---- the first imperial dynasty of China(not to be confused with the Qing Dynasty, the last dynasty of China). So Ying Zheng named himself "Qin Shi Huang" because "Shi Huang" means "the first emperor" in Chinese.


Qin Shi Huang undertook gigantic projects, including the first version of the Great Wall of China, the now famous city-sized mausoleum guarded by a life-sized Terracotta Army, and a massive national road system. There is a story about the road system:
There were n cities in China and Qin Shi Huang wanted them all be connected by n-1 roads, in order that he could go to every city from the capital city Xianyang.
Although Qin Shi Huang was a tyrant, he wanted the total length of all roads to be minimum,so that the road system may not cost too many people's life. A daoshi (some kind of monk) named Xu Fu told Qin Shi Huang that he could build a road by magic and that magic road would cost no money and no labor. But Xu Fu could only build ONE magic road for Qin Shi Huang. So Qin Shi Huang had to decide where to build the magic road. Qin Shi Huang wanted the total length of all none magic roads to be as small as possible, but Xu Fu wanted the magic road to benefit as many people as possible ---- So Qin Shi Huang decided that the value of A/B (the ratio of A to B) must be the maximum, which A is the total population of the two cites connected by the magic road, and B is the total length of none magic roads.
Would you help Qin Shi Huang?
A city can be considered as a point, and a road can be considered as a line segment connecting two points.

 

 

Input

The first line contains an integer t meaning that there are t test cases(t <= 10).
For each test case:
The first line is an integer n meaning that there are n cities(2 < n <= 1000).
Then n lines follow. Each line contains three integers X, Y and P ( 0 <= X, Y <= 1000, 0 < P < 100000). (X, Y) is the coordinate of a city and P is the population of that city.
It is guaranteed that each city has a distinct location.

 

 

Output

For each test case, print a line indicating the above mentioned maximum ratio A/B. The result should be rounded to 2 digits after decimal point.

 

 

Sample Input

 

2 4 1 1 20 1 2 30 200 2 80 200 1 100 3 1 1 20 1 2 30 2 2 40

 

 

Sample Output

 

65.00 70.00

 

参考 https://blog.csdn.net/shuangde800/article/details/7982106

#include<cstdio>
#include<cstring>
#include<iostream>
#include<cmath>
#define INF 2147483647
#define N 1005
using namespace std;

double G[N][N], minCost[N], pos[N][2], path[N][N], cost[N], ratio, A, B;
int pre[N], hashs[N], n;
bool used[N][N];

inline double getDist(double x1,double y1,double x2,double y2)
{
    return sqrt((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2));
}

double Prim()
{
    A=B=0;
    memset(hashs, 0, sizeof(hashs));
    memset(used, 0, sizeof(used));
    memset(path, 0, sizeof(path));
    hashs[1]=1;//以1为起点
    for(int i=1; i<=n; ++i)
    {
        minCost[i] = G[1][i];
        pre[i] = 1;
    }
    for(int i=1; i<n; ++i)
    {
        int u=-1;
        for(int j=1; j<=n; ++j)
            if(!hashs[j])
            {
                if(u==-1 || minCost[j]<minCost[u])
                    u = j;
            }//不断求距离第一个点最短距离;
        used[u][pre[u]]=used[pre[u]][u] = true;//被用了;
        B += G[pre[u]][u];//B是最小生成树
        hashs[u] = 1;//用了这个u点
        for(int j=1; j<=n; ++j)
        {
            if(hashs[j]&&j!=u)
            {
                path[u][j]=path[j][u]=max(path[j][pre[u]], minCost[u]);//成环后的最大边
            }
            if(!hashs[j])
            {
                if(minCost[j]>G[u][j])
                {
                    minCost[j] = G[u][j];//minCost[j]相当于是1到j的最短路径
                    pre[j] = u;//j的前一个点是u                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                      
                }
            }
        }
    }
    return B;
}

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        memset(G, 0, sizeof(G));
        for(int i=1; i<=n; ++i)
            scanf("%lf%lf%lf",&pos[i][0],&pos[i][1],&cost[i]);//横纵坐标;
        for(int i=1; i<=n; ++i)
        {
            for(int j=1; j<=n; ++j)
                if(i!=j)
                {
                    G[i][j] = getDist(pos[i][0],pos[i][1],pos[j][0],pos[j][1]);//得到距离
                }
        }
        Prim();
        ratio = -1;
        for(int i=1; i<=n; ++i)
        {
            for(int j=1; j<=n; ++j)
                if(i!=j)
                {
                    if(used[i][j]) //i-j在最小生成树中
                    {
                        ratio = max(ratio, (cost[i]+cost[j])/(B-G[i][j]));
                    }
                    else //不在就减去和它成环的最大边;
                    {
                        ratio = max(ratio, (cost[i]+cost[j])/(B-path[i][j]));
                    }
                }
        }
        printf("%.2f\n", ratio);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值