HDU - 4081

Description

During the Warring States Period of ancient China(476 BC to 221 BC), there were seven kingdoms in China ---- they were Qi, Chu, Yan, Han, Zhao, Wei and Qin. Ying Zheng was the king of the kingdom Qin. Through 9 years of wars, he finally conquered all six other kingdoms and became the first emperor of a unified China in 221 BC. That was Qin dynasty ---- the first imperial dynasty of China(not to be confused with the Qing Dynasty, the last dynasty of China). So Ying Zheng named himself "Qin Shi Huang" because "Shi Huang" means "the first emperor" in Chinese. 

Qin Shi Huang undertook gigantic projects, including the first version of the Great Wall of China, the now famous city-sized mausoleum guarded by a life-sized Terracotta Army, and a massive national road system. There is a story about the road system: 
There were n cities in China and Qin Shi Huang wanted them all be connected by n-1 roads, in order that he could go to every city from the capital city Xianyang. 
Although Qin Shi Huang was a tyrant, he wanted the total length of all roads to be minimum,so that the road system may not cost too many people's life. A daoshi (some kind of monk) named Xu Fu told Qin Shi Huang that he could build a road by magic and that magic road would cost no money and no labor. But Xu Fu could only build ONE magic road for Qin Shi Huang. So Qin Shi Huang had to decide where to build the magic road. Qin Shi Huang wanted the total length of all none magic roads to be as small as possible, but Xu Fu wanted the magic road to benefit as many people as possible ---- So Qin Shi Huang decided that the value of A/B (the ratio of A to B) must be the maximum, which A is the total population of the two cites connected by the magic road, and B is the total length of none magic roads. 
Would you help Qin Shi Huang? 
A city can be considered as a point, and a road can be considered as a line segment connecting two points.
 

Input

The first line contains an integer t meaning that there are t test cases(t <= 10). 
For each test case: 
The first line is an integer n meaning that there are n cities(2 < n <= 1000). 
Then n lines follow. Each line contains three integers X, Y and P ( 0 <= X, Y <= 1000, 0 < P < 100000). (X, Y) is the coordinate of a city and P is the population of that city. 
It is guaranteed that each city has a distinct location.
 

Output

For each test case, print a line indicating the above mentioned maximum ratio A/B. The result should be rounded to 2 digits after decimal point.
 

Sample Input

    
    
2 4 1 1 20 1 2 30 200 2 80 200 1 100 3 1 1 20 1 2 30 2 2 40
 

Sample Output

    
    
65.00

70.00

好久没整理过题目了 一直在乱作 = = 考完试啦 快放假啦 暑假集训也要开始了 不知道会被虐成啥样。。不过无所谓 今天被虐哭明天还可以哭着做~ 不知道有木有这么惨 = = 废话废话 这题貌似是个次小生成树 先用Prim求出最小生成树 然后枚举边 因为以前习惯用Kruskal 但这个用Prim可以方便的求出最小生成树中用到的哪些边。。之间最大的权值是多少 在后来枚举边的时候 如果那条边在使用 那么比值就是(es[i].p+es[j].p)/(sum-G[i][j]),如果是没使用过的边 那么加上后必然形成环 那么就要在原来的图中去掉一条权值最大的边。

#include <bits/stdc++.h>
using namespace std;
const int maxn = 1005;
int T,n,use[maxn][maxn],vis[maxn],pre[maxn];
double G[maxn][maxn],Max[maxn][maxn],mincost[maxn],sum;
struct c{
    double x,y,p;
    c():x(0),y(0),p(0){}
    bool operator < (const c& t)const {return p<t.p;}
}es[maxn];
double distance(double x1,double y1,double x2,double y2){
    return sqrt((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2));
}
void prim(int v0){
     sum=0;
     for(int i=1;i<=n;i++){
         mincost[i]=G[v0][i];
         pre[i]=v0;
     }
     vis[v0]=1;
     for(int i=1;i<n;i++){
         double minn=0x7f7f7f7f;
        int v=-1;
         for(int j=1;j<=n;j++)
             if(!vis[j]&&mincost[j]<minn)
                 v=j,minn=mincost[j];
         if(v!=-1){
             sum+=mincost[v];
             use[v][pre[v]]=use[pre[v]][v]=1;
             vis[v]=1;
             for(int k=1;k<=n;k++){
                 if(vis[k]&&k!=v){
                     Max[v][k]=Max[k][v]=(Max[k][pre[v]]>mincost[v]?Max[k][pre[v]]:mincost[v]);
                 }
                 if(!vis[k]&&G[v][k]<mincost[k]){
                     mincost[k]=G[v][k];
                     pre[k]=v;
                 }
             }
         }
     }
 }
int main(){
    scanf("%d",&T);
    while(T--){
        memset(use,0,sizeof(use));
        memset(vis,0,sizeof(vis));
        memset(Max,0,sizeof(Max));
        memset(pre,0,sizeof(pre));
        memset(G,0,sizeof(G));
        memset(mincost,0,sizeof(mincost));
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
            scanf("%lf%lf%lf",&es[i].x,&es[i].y,&es[i].p);
        for(int i=1;i<=n;i++)
        for(int j=i+1;j<=n;j++)
            G[i][j]=G[j][i]=distance(es[i].x,es[i].y,es[j].x,es[j].y);
        prim(1);
        double ans = -1;
        for(int i=1;i<=n;i++){
            for(int j=1;j<=n;j++){
                if(i==j) continue;
                if(use[i][j])
                    ans=max(ans,(es[i].p+es[j].p)/(sum-G[i][j]));
                else
                    ans=max(ans,(es[i].p+es[j].p)/(sum-Max[i][j]));
            }
        }
        printf("%.2f\n",ans);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值