HDU5573 Binary Tree 二进制+规律

The Old Frog King lives on the root of an infinite tree. According to the law, each node should connect to exactly two nodes on the next level, forming a full binary tree. 

Since the king is professional in math, he sets a number to each node. Specifically, the root of the tree, where the King lives, is 11. Say froot=1froot=1. 

And for each node uu, labels as fufu, the left child is fu×2fu×2 and right child is fu×2+1fu×2+1. The king looks at his tree kingdom, and feels satisfied. 

Time flies, and the frog king gets sick. According to the old dark magic, there is a way for the king to live for another NN years, only if he could collect exactly NN soul gems. 

Initially the king has zero soul gems, and he is now at the root. He will walk down, choosing left or right child to continue. Each time at node xx, the number at the node is fxfx (remember froot=1froot=1), he can choose to increase his number of soul gem by fxfx, or decrease it by fxfx. 

He will walk from the root, visit exactly KK nodes (including the root), and do the increasement or decreasement as told. If at last the number is NN, then he will succeed. 

Noting as the soul gem is some kind of magic, the number of soul gems the king has could be negative. 

Given NN, KK, help the King find a way to collect exactly NN soul gems by visiting exactly KK nodes.

Input

First line contains an integer TT, which indicates the number of test cases. 

Every test case contains two integers NN and KK, which indicates soul gems the frog king want to collect and number of nodes he can visit. 

⋅⋅ 1≤T≤1001≤T≤100. 

⋅⋅ 1≤N≤1091≤N≤109. 

⋅⋅ N≤2K≤260N≤2K≤260.

Output

For every test case, you should output " Case #x:" first, where xxindicates the case number and counts from 11. 

Then KK lines follows, each line is formated as 'a b', where aa is node label of the node the frog visited, and bb is either '+' or '-' which means he increases / decreases his number by aa. 

It's guaranteed that there are at least one solution and if there are more than one solutions, you can output any of them. 
 

Sample Input

2
5 3
10 4

Sample Output

Case #1:
1 +
3 -
7 +
Case #2:
1 +
3 +
6 -
12 +

根据二进制规律,只走最左边的那一条道路,根据n>>i判断正负号,特判最后一个数,如果是奇数就直接输出

偶数的话向右拐一下,比原来大1,因为初始的时间减去了1.

#include<bits/stdc++.h>
using namespace std;
long long n,k;
int flag = 0;
int a[666];
int main()
{
//只走二叉树的最左边那个道路,
    int t;
    scanf("%d",&t);
    for(int cases=1; cases<=t; cases++)
    {
        scanf("%lld%lld",&n,&k);
        flag = 0;
        memset(a,0,sizeof(a));
        if(n%2==0)
        {
            flag = 1;
            n = n-1;//偶数的情况,把它变成奇数;
        }
        int tmp = 0;
        for(int i=k-1; i>=0; i--)
        {//找规律,看哪些需要+,哪些需要减;
            a[i]=1-tmp;
            tmp=1;
            if((n>>i)&1)
                tmp=0;
            //cout<<(n>>i)<<"dfsd"<<((n>>i)&1)<<endl;
        }//
        printf("Case #%d:\n",cases);
        long long now = 1;
        for(int i=0; i<k-1; i++)
        {
            printf("%lld ",now);
            now = now*2;//只输出2的n次方;
            if(a[i])printf("+\n");
            else printf("-\n");//
        }
        if(flag)printf("%lld ",now+1);
        else printf("%lld ",now);//如果是偶数,那么往右拐一下;
        if(a[k-1])printf("+\n");
        else printf("-\n");
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值