hdu 1542 Atlantis 扫描线+线段树+离散化

There are several ancient Greek texts that contain descriptions of the fabled island Atlantis. Some of these texts even include maps of parts of the island. But unfortunately, these maps describe different regions of Atlantis. Your friend Bill has to know the total area for which maps exist. You (unwisely) volunteered to write a program that calculates this quantity. 

Input

The input file consists of several test cases. Each test case starts with a line containing a single integer n (1<=n<=100) of available maps. The n following lines describe one map each. Each of these lines contains four numbers x1;y1;x2;y2 (0<=x1<x2<=100000;0<=y1<y2<=100000), not necessarily integers. The values (x1; y1) and (x2;y2) are the coordinates of the top-left resp. bottom-right corner of the mapped area. 

The input file is terminated by a line containing a single 0. Don’t process it.

Output

For each test case, your program should output one section. The first line of each section must be “Test case #k”, where k is the number of the test case (starting with 1). The second one must be “Total explored area: a”, where a is the total explored area (i.e. the area of the union of all rectangles in this test case), printed exact to two digits to the right of the decimal point. 

Output a blank line after each test case. 

Sample Input

2
10 10 20 20
15 15 25 25.5
0

Sample Output

Test case #1
Total explored area: 180.00 

参考 https://blog.csdn.net/Merry_hj/article/details/77100290 这篇讲的很详细 

#include<iostream>
#include<stdio.h>
#include<algorithm>
using namespace std;
struct lines
{
    double x;
    double y_up;
    double y_down;
    int flag;
}line[220];
bool cmp(lines a,lines b)
{
    return a.x<b.x;
}
double y[220];
double x1,y1,x2,y2;
int n,index=0;
struct Tree
{
    double x,y_up,y_down;
    bool flag;//用来标记是否是叶子节点
    int cover;
}tree[1000*110];
void build(int i, int l, int r)
{
       tree[i].x = 0; //表示该节点上一条的x的值
       tree[i].cover = 0; //表示该区间上有多少条线段;左边线段加进去则++,右边线段加进去则--
       tree[i].y_down = y[l];
       tree[i].y_up = y[r];
       tree[i].flag = false;
       if(l+1==r)
       {
           tree[i].flag = true; //flag==true表示达到了叶子节点
           return;
       }
       int mid=(l+r)>>1;
       build(2*i, l, mid);
       build(2*i+1, mid, r);
}
double ins(int i,double x,double l,double r,int flag)
{
    if(r<=tree[i].y_down||l>=tree[i].y_up)//说明查找的这一条线不在当前节点的区间
        return 0;
    if(tree[i].flag)//叶子节点
    {
        if(tree[i].cover > 0)//大于0表示被覆盖
        {
            double temp_x=tree[i].x;
            double ans=(x-temp_x)*(tree[i].y_up - tree[i].y_down);
            tree[i].x = x;   //定位上一次的x
            tree[i].cover += flag;
            return ans;
        }
        else
        {
            tree[i].cover += flag;
            tree[i].x = x;   //定位上一次的x
            return 0;
        }

    }
    double ans1, ans2;
    ans1 = ins(2*i, x, l, r, flag);
    ans2 = ins(2*i+1, x, l, r, flag);
    //cout<<ans1<<' '<<ans2<<endl;
    return ans1+ans2;

}
int main()
{
    int count1=0;
    while(scanf("%d",&n),n)
    {
        index=1;
        for(int i=1;i<=n;i++)
        {//给定矩形左下右上坐标
           scanf("%lf%lf%lf%lf",&x1,&y1,&x2,&y2);
            y[index]=y1;
            line[index].x=x1;//记录扫描线的横坐标
            line[index].y_down=y1;//纵下坐标
            line[index].flag=1;//是左右边界
            line[index++].y_up=y2;//纵上坐标
            y[index]=y2;
            line[index].x=x2;
            line[index].y_down=y1;
            line[index].y_up=y2;
            line[index].flag=-1;
            index++;//右上点
        }
        sort(y+1,y+index);//离散化y坐标
        sort(line+1,line+index,cmp);//根据x从小到大排序
        build(1,1,index-1);
        double ans=0;
        for(int i=1;i<index;i++)
        {
            ans+=ins(1,line[i].x,line[i].y_down,line[i].y_up,line[i].flag);
        }
        printf("Test case #%d\nTotal explored area: %.2f\n\n", ++count1, ans);
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值