HDU-1542 Atlantis 矩形+线段树+扫描线

HUD链接:HDU-1542 Atlantis
牛客的链接:牛客 Atlantis

Problem Description

There are several ancient Greek texts that contain descriptions of the fabled island Atlantis. Some of these texts even include maps of parts of the island. But unfortunately, these maps describe different regions of Atlantis. Your friend Bill has to know the total area for which maps exist. You (unwisely) volunteered to write a program that calculates this quantity.

Input

The input file consists of several test cases. Each test case starts with a line containing a single integer n (1<=n<=100) of available maps. The n following lines describe one map each. Each of these lines contains four numbers x1;y1;x2;y2 (0<=x1<x2<=100000;0<=y1<y2<=100000), not necessarily integers. The values (x1; y1) and (x2;y2) are the coordinates of the top-left resp. bottom-right corner of the mapped area.

The input file is terminated by a line containing a single 0. Don’t process it.

Output

For each test case, your program should output one section. The first line of each section must be “Test case #k”, where k is the number of the test case (starting with 1). The second one must be “Total explored area: a”, where a is the total explored area (i.e. the area of the union of all rectangles in this test case), printed exact to two digits to the right of the decimal point.

Output a blank line after each test case.

Sample Input

2
10 10 20 20
15 15 25 25.5
0

Sample Output

Test case #1
Total explored area: 180.00

题意

求给出n个矩形的左上和右下坐标,求这些矩形围成的面积。

题解

QAQ照着别人的代码模仿的
离散化纵坐标和横坐标
按照横坐标从左到右扫描,且用线段树维护纵坐标差大小

#pragma GCC optimize(2)
#include<bits/stdc++.h> 
using namespace std;
#define ll long long
#define endl "\n"
const int MAX=1e3+7;
int lz[MAX<<3];
double s[MAX<<3]; //离散化矩形边界按纵坐标从小到大排序 
struct node1{   //线段树 
	double l,r,sum;
}cl[MAX<<3];
struct node2{   //矩形 
	double x,y1,y2;
	int f;
	operator<(const node2 t)const{return x<t.x;}  //按照横坐标从小到大排序 
}p[MAX<<3];
void push_up(int rt){
	if(lz[rt]>0)cl[rt].sum=cl[rt].r-cl[rt].l;
	else cl[rt].sum=cl[rt*2].sum+cl[rt*2+1].sum;
}
void build(int l,int r,int rt){ //建树 
	if(r-l>1){
		cl[rt].l=s[l];
		cl[rt].r=s[r];
		build(l,(l+r)/2,rt*2);
		build((l+r)/2,r,rt*2+1);
		push_up(rt);
	}
	else{
		cl[rt].l=s[l];
		cl[rt].r=s[r];
		cl[rt].sum=0;   
	}
	return ;
}
void update(double y1,double y2,int rt,int f){  //更新 
	if(cl[rt].l==y1&&cl[rt].r==y2){
		lz[rt]+=f;
		push_up(rt);
		return ;
	}
	else {
		if(cl[rt*2].r>y1) update(y1,min(cl[rt*2].r,y2),rt*2,f);
		if(cl[rt*2+1].l<y2) update(max(cl[rt*2+1].l,y1),y2,rt*2+1,f); 
		push_up(rt);
	} 
}
int main(){
    ios_base::sync_with_stdio(0);cin.tie(0),cout.tie(0);
	int n,cas=1;
	double x1,x2,y1,y2,ans;
	while(cin>>n&&n){
		ans=0;
		for(int i=0;i<n;i++){
			cin>>x1>>y1>>x2>>y2;
			p[i].x=x1,p[i].y1=y1,p[i].y2=y2; 
			p[i+n].x=x2,p[i+n].y1=y1,p[i+n].y2=y2; 
			p[i].f=1,p[i+n].f=-1;
			s[i+1]=y1,s[i+n+1]=y2;
		}
		sort(s+1,s+2*n+1);   //y 
		sort(p,p+2*n);       //x
		build(1,2*n,1);
		memset(lz,0,sizeof(lz));
		update(p[0].y1,p[0].y2,1,p[0].f);  
		for(int i=1;i<2*n;i++){
			ans+=(p[i].x-p[i-1].x)*cl[1].sum;
			update(p[i].y1,p[i].y2,1,p[i].f); 
		}
		cout<<"Test case #"<<cas++<<endl;
		cout<<"Total explored area: "<<fixed<<setprecision(2)<<ans<<endl<<endl;//要求多输出一行  
	}
   return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值