POJ 2566 尺取法+前缀和排序

Signals of most probably extra-terrestrial origin have been received and digitalized by The Aeronautic and Space Administration (that must be going through a defiant phase: "But I want to use feet, not meters!"). Each signal seems to come in two parts: a sequence of n integer values and a non-negative integer t. We'll not go into details, but researchers found out that a signal encodes two integer values. These can be found as the lower and upper bound of a subrange of the sequence whose absolute value of its sum is closest to t. 

You are given the sequence of n integers and the non-negative target t. You are to find a non-empty range of the sequence (i.e. a continuous subsequence) and output its lower index l and its upper index u. The absolute value of the sum of the values of the sequence from the l-th to the u-th element (inclusive) must be at least as close to t as the absolute value of the sum of any other non-empty range.

Input

The input file contains several test cases. Each test case starts with two numbers n and k. Input is terminated by n=k=0. Otherwise, 1<=n<=100000 and there follow n integers with absolute values <=10000 which constitute the sequence. Then follow k queries for this sequence. Each query is a target t with 0<=t<=1000000000.

Output

For each query output 3 numbers on a line: some closest absolute sum and the lower and upper indices of some range where this absolute sum is achieved. Possible indices start with 1 and go up to n.

Sample Input

5 1
-10 -5 0 5 10
3
10 2
-9 8 -7 6 -5 4 -3 2 -1 0
5 11
15 2
-1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1
15 100
0 0

Sample Output

5 4 4
5 2 8
9 1 1
15 1 15
15 1 15

 

#include<iostream>
#include<stdio.h>
#include<math.h>
#include<algorithm>
#define ll long long
#define pb push_back
#define fi first
#define se second
#define pi acos(-1)
#define inf 0x3f3f3f3f
#define lson l,mid,rt<<1
#define rson mid+1,r,rt<<1|1
#define rep(i,x,n) for(int i=x;i<n;i++)
#define per(i,n,x) for(int i=n;i>=x;i--)
using namespace std;
typedef pair<int,int>P;//pair类型 数据结构P
const int MAXN=100010;
int n;
P p[MAXN];//数组p
void solve(int t)
{
    int sum, l = 0, r = 1;//尺取法
    int ul, ur, tmp = inf, ans;
    while(r <= n)
    {
        sum = p[r].fi - p[l].fi;
        //cout<<sum<<"ss"<<p[r].fi<<"cc"<<p[l].fi<<endl;
        if(abs(sum - t) < tmp)
        {
            tmp = abs(sum - t);//更新差值
            ul = p[l].se;//左边界
            ur = p[r].se;//右边界
            ans = sum;//保存答案
        }
        if(sum < t)
            r++;//右边界+,sum还小于t,那就向右移,增大sum的值
        else
            l++;//左边界+,否则就让左边界增大,减小sum值
        if(l == r)
            r++;//向右看,子序列不能为空;
    }
    if(ul > ur)
        swap(ul, ur);//大小;
    cout << abs(ans) << " " << ul + 1 << " " << ur << endl;
}
int main()
{
    int k, t;
    while(~scanf("%d %d", &n, &k), n + k)
    {
        int sum = 0;
        p[0] = P(0, 0);
        for(int i = 1; i <= n; i++)
        {
            scanf("%d", &t);
            sum += t;//处理前缀和
            cout<<sum<<"ssuuuuuuus"<<endl;
            p[i] = P(sum, i);//存储前缀和和右边界
        }
        sort(p, p + n + 1);//对其进行排序
        //cout<<p[0].fi<<"xxxxxxxxxxxxxxx"<<endl;
        while(k--)
        {
            scanf("%d", &t);
            solve(t);//函数
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值