SPFA求最短路+判断负环+差分约束

Nowadays, many people want to go to Shanghai to visit the World Exhibition. So there are always a lot of people who are standing along a straight line waiting for entering. Assume that there are N (2 <= N <= 1,000) people numbered 1..N who are standing in the same order as they are numbered. It is possible that two or more person line up at exactly the same location in the condition that those visit it in a group. 

There is something interesting. Some like each other and want to be within a certain distance of each other in line. Some really dislike each other and want to be separated by at least a certain distance. A list of X (1 <= X <= 10,000) constraints describes which person like each other and the maximum distance by which they may be separated; a subsequent list of Y constraints (1 <= Y <= 10,000) tells which person dislike each other and the minimum distance by which they must be separated. 

Your job is to compute, if possible, the maximum possible distance between person 1 and person N that satisfies the distance constraints. 

Input

First line: An integer T represents the case of test. 

The next line: Three space-separated integers: N, X, and Y. 

The next X lines: Each line contains three space-separated positive integers: A, B, and C, with 1 <= A < B <= N. Person A and B must be at most C (1 <= C <= 1,000,000) apart. 

The next Y lines: Each line contains three space-separated positive integers: A, B, and C, with 1 <= A < B <= C. Person A and B must be at least C (1 <= C <= 1,000,000) apart. 

Output

For each line: A single integer. If no line-up is possible, output -1. If person 1 and N can be arbitrarily far apart, output -2. Otherwise output the greatest possible distance between person 1 and N.

Sample Input

1
4 2 1
1 3 8
2 4 15
2 3 4

Sample Output

19

给你n,x,y x代表以后输入的ABC AB之间最大距离是C B-A<=C所以 加边 A->B 权值为C

y则反之 B-A>=C->A-B<=-C->边B->A权值为-C,以1为源点,如果有负环直接输出-1,没有看能否1到达n

#include <bits/stdc++.h>

using namespace std;
const int maxn=1100;
const int maxm=21000;
const int INF=0x3f3f3f3f;
struct node
{
    int to;
    int va;
    int next;
} edge[maxm];
int dis[maxn],vis[maxn],used[maxn],head[maxn];
queue<int>Q;
int ans=0;
int N;
void add(int u,int v,int w)
{
    edge[ans].to=v;
    edge[ans].va=w;
    edge[ans].next=head[u];
    head[u]=ans++;
}
void init()
{
    ans=0;
    memset(used,0,sizeof(used));
    memset(vis,0,sizeof(vis));
    memset(head,-1,sizeof(head));

}
int spfa(int root)
{
    for(int i=1; i<=N; i++)
        dis[i]=INF;//初始化为无穷,所求是最大值最短路
    while(!Q.empty())
        Q.pop();
    Q.push(root);
    dis[root]=0;//入队,标记距离
    vis[root]=1;
    used[root]++;
    while(!Q.empty())
    {
        int u=Q.front();
        Q.pop();
        vis[u]=0;
        for(int i=head[u]; i!=-1; i=edge[i].next)
        {
            node e=edge[i];
            int v=e.to;
            if(dis[v]>dis[u]+e.va)
            {
                dis[v]=dis[u]+e.va;
                if(!vis[v])
                {
                    vis[v]=1;
                    used[v]++;//判断是否会出现负环
                    if(used[v]>N)
                    {
                        return -1;
                    }
                    Q.push(v);
                }
            }
        }
    }
    return 0;
}

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        init();
        int n,x,y;
        scanf("%d%d%d",&n,&x,&y);
        int u,v,w;
        N=n;
        for(int i=1; i<=x; i++)
        {
            scanf("%d%d%d",&u,&v,&w);
            add(u,v,w);
        }
        for(int i=1; i<=y; i++)
        {
            scanf("%d%d%d",&u,&v,&w);
            add(v,u,-w);
        }
        int f=spfa(1);
        if(!f)
        {
            if(dis[n]==INF)
            {
                printf("-2\n");
            }
            else
                printf("%d\n",dis[n]);
        }
        else
            printf("%d\n",f);
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值