UVA_455

题目链接:
https://cn.vjudge.net/problem/UVA-455


Input
The first line oif the input file will contain a single integer N indicating how many test case that your
program will test followed by a blank line. Each test case will contain a single character string of up
to 80 non-blank characters. Two consecutive input will separated by a blank line.
Output
An integer denoting the smallest period of the input string for each input. Two consecutive output are
separated by a blank line.
Sample Input
1
HoHoHo
Sample Output
2
#include <iostream>
#include <cstdlib>
#include <cstring>
#include <cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;  
char str[1001];
 
int main()
{
	int T;
	cin>>T;
	while (T--) {
		scanf("%s",str);
		int len = strlen(str); 
		for (int i = 1 ; i <= len ; ++ i)
			if (len%i == 0) {
				int k;
				for (k = i ; k < len ; ++ k)
					if (str[k] != str[k%i])
						break;
				if (k==len) {
					printf("%d\n",i);
					break;
				}
			}
		if (T) printf("\n");
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值