PAT 1004 Counting Leaves (30) Python

题目代码

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.
Input

Each input file contains one test case. Each case starts with a line containing 0 < N < 100, the number of nodes in a tree, and M (< N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.
Output

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output "0 1" in a line.

Sample Input
2 1
01 1 02
Sample Output

解题思路

在根据输入建立好家族树的数据结构后,然后进行一次层序遍历,依次计算叶子节点的个数。

解题注意点

需要注意N=1,M=0的情况,此时node_dict中没有任何Key,如果没有处理就会Keyrerror导致运行错误。

以及在设置函数Python的默认参数需要注意,尽量不要设置默认参数为可变对象,并不会每次调用函数就会创建一个新的可变对象,而是维持对第一次创建可变对象的引用,可以参考这篇文章:Using a mutable default value as an argument

在定义Node中错误的写法:

class Node(object):

    def __init__(self, ID, parent=None, children=[]):
        self.id = ID
        self.parent = parent
        self.children = children

>>> from PAT1004 import Node
>>> first = Node('01')
>>> first.children.append('something')
>>> second = Node('02')
>>> second.children
['something']

代码

class Node(object):

    def __init__(self, ID, parent=None, children=None):
        self.id = ID
        self.parent = parent
        if children is None:
            self.children = []
        else:
            self.children = children

    def child_append(self, other):
        if isinstance(other, list):
            self.children += other
        else:
            self.children.append(other)


def main():
    nodes, non_leaf = [int(_) for _ in input().split()]
    if nodes == 1:
        print("1", end='')
        return

    nodes_dict = {}

    for i in range(non_leaf):
        leaf_id, children, *children_id = input().split()
        if leaf_id not in nodes_dict:
            leaf_node = Node(ID=leaf_id)
            nodes_dict[leaf_id] = leaf_node
        else:
            leaf_node = nodes_dict[leaf_id]

        for child in children_id:
            if child not in nodes_dict:
                child_node = Node(ID=child, parent=leaf_node)
                nodes_dict[child] = child_node
            else:
                child_node = nodes_dict[child]
                child_node.parent = leaf_node

            leaf_node.child_append(child_node)

    root_queue = [nodes_dict['01']]
    res = []

    def recursive(layer_queue):
        nonlocal res
        if layer_queue:
            non_leaf_num = 0
            next_queue = []
            for node in layer_queue:
                if not node.children:
                    non_leaf_num += 1
                else:
                    next_queue += node.children

            res.append(non_leaf_num)
            recursive(next_queue)

    recursive(root_queue)
    res = [str(_) for _ in res]
    print(' '.join(res), end='')

if __name__ == '__main__':
    main()
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值