1004 Counting Leaves (30 分)
A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.
Input Specification:
Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:
ID K ID[1] ID[2] … ID[K]
where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID’s of its children. For the sake of simplicity, let us fix the root ID to be 01.
The input ends with N being 0. That case must NOT be processed.
Output Specification:
For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.
The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.
Sample Input:
2 1
01 1 02
Sample Output:
0 1
做题思路:ID数组接收父级,如果有父级则寻找是否有子级,有则跳过,无则递归寻找层级n,该层级数组K[n]++
问题:测试点2过不了,不知道问题在哪里。枯了qwq
#include<iostream>
using namespace std;
int ID[105] = { -1 }, leaf[105] = { 0 };
int hi = 0;
void findfa(int x, int h)//递归寻找层级
{
if (x == 1)
{
leaf[h]++;
if (hi < h)
hi = h;
return;
}
h++;
findfa(ID[x], h);
}
int main()
{
for (int i = 0; i < 100; i++)
{
ID[i] = -1;
}
int N, M;
cin >> N;
if (N == 0)
return 0;
cin >> M;
for (int i = M; i > 0; i--)//输入
{
int x, y;
cin >> x >> y;
while (y)
{
int u;
cin >> u; ID[u] = x;
y--;
}
}
for (int i = 0; i < 100; i++)//具有父级则检查是否有子级
{
if (ID[i] != -1)
for (int j = 0; j < 100; j++)
if (ID[j] == i)
break;
else if (j == 99)
findfa(i, 0);
}
cout << leaf[0];
for (int i = 1; i <= hi; i++)
{
cout << " " << leaf[i];
}
system("pause");
return 0;
}