【Binary String Matching 5】

Binary String Matching

时间限制: 3000 ms  |  内存限制: 65535 KB
难度: 3
描述
Given two strings A and B, whose alphabet consist only ‘0’ and ‘1’. Your task is only to tell how many times does A appear as a substring of B? For example, the text string B is ‘1001110110’ while the pattern string A is ‘11’, you should output 3, because the pattern A appeared at the posit
输入
The first line consist only one integer N, indicates N cases follows. In each case, there are two lines, the first line gives the string A, length (A) <= 10, and the second line gives the string B, length (B) <= 1000. And it is guaranteed that B is always longer than A.
输出
For each case, output a single line consist a single integer, tells how many times do B appears as a substring of A.
样例输入
3
11
1001110110
101
110010010010001
1010
110100010101011 
样例输出
3
0
3 
#include<iostream>
#include<string>
using namespace std;
int main(){
	int N;
	cin>>N;
	while(N--){
		string a,b;
		cin>>a>>b;
		int count=0;
		for(string::size_type ix=0;ix!=b.size();ix++){
			int ok=1;
			for(string::size_type i=0;i!=a.size();i++){
				if(b[ix+i]!=a[i])
					ok=0;
			}
			if(ok)
				count++;
	}
		cout<<count<<endl;
	}
}

字符一一匹配。

最佳代码:用的find()的函数。

#include<iostream>
#include<string>
using namespace std;
int main(){
	string s1,s2;
	int N;
	cin>>N;
	while(N--){
		cin>>s1>>s2;
		string::size_type m=s2.find(s1,0);
		int num=0;
		while(m!=string::npos){
			num++;
			m=s2.find(s1,m+1);
		}	
		cout<<num<<endl;
	}
}
关于find()和string::nops  想了解请点击我

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

paidream

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值