【A+B Problem II 103】

A+B Problem II

时间限制: 3000 ms  |  内存限制: 65535 KB
难度: 3
描述

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

A,B must be positive.

输入
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
输出
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation.
样例输入
2
1 2
112233445566778899 998877665544332211
样例输出
Case 1:
1 + 2 = 3
Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110
#include<cstdio>
#include<cstring>
int test=0;
struct Num{
	int len;
	char num[1000+5];
}A,B;
void Init(Num &a){
	a.len=strlen(a.num);
}
void swap(char &a,char &b){
	char t=a;
	a=b;
	b=t;
}
void Reverse(Num &a){
	a.len=strlen(a.num);
	for(int i=0;i<a.len-i-1;i++)
		swap(a.num[i],a.num[a.len-1-i]);
}
void add(Num &a,Num &b){
	Reverse(a);
	a.num[a.len]='0';
	for(int i=0;i<a.len;i++){
		if(b.len-1-i>=0){
			a.num[i]+=b.num[b.len-1-i]-'0';
		}
		if(a.num[i]>'9'){
			a.num[i+1]++;
			a.num[i]-=10;
		}


	}
	int max_len=a.num[a.len]=='0'?a.len-1:a.len;
	for(int j=max_len;j>=0;j--)
		printf("%c",a.num[j]);
	printf("\n");
	
}
int main(){
	int n;
	scanf("%d",&n);
	while(n--){
		scanf("%s%s",A.num,B.num);
		Init(A);
		Init(B);
		printf("Case %d:\n",++test);
		for(int i=0;i<A.len;i++)
			printf("%c",A.num[i]);
		printf(" + ");
		for(int j=0;j<B.len;j++)
			printf("%c",B.num[j]);
		printf(" = ");
		A.len>B.len?add(A,B):add(B,A);

		
	}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

paidream

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值