杭电OJ A + B Problem II

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 310934    Accepted Submission(s): 60113


Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
  
  
2 1 2 112233445566778899 998877665544332211
 

Sample Output
  
  
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
 

Author
Ignatius.L
//2016年6月17日11:38:03
# include <stdio.h>
# include <string.h>
int main (void)
{
    int T, i;
    int iSum[1000];
    char cNum1[1000], cNum2[1000];
    int iCount1, iCount2;
    int t, j, g, count;
    scanf ("%d", &T);
    for (i = 0; i < T; i++)
    {
        t = 0;
        j = 0;
        count = 0;
        scanf ("%s %s", cNum1, cNum2);
        printf ("Case %d:\n", i+1);
        printf ("%s + %s = ", cNum1, cNum2);
        iCount1 = strlen(cNum1)-1;
        iCount2 = strlen(cNum2)-1;
        while (iCount1 >= 0 && iCount2 >= 0)
        {
            iSum[j] = cNum1[iCount1]-'0'+cNum2[iCount2]-'0'+t;
            t = iSum[j]/10;
            iSum[j] = iSum[j]%10;
            j++;
            iCount1--;
            iCount2--;
            count++;
        }
        while (iCount1 >= 0)
        {
            iSum[j] = cNum1[iCount1]-'0'+t;
            t = iSum[j]/10;
            iCount1--;
            j++;
        }
        while (iCount2 >= 0)
        {
            iSum[j] = cNum2[iCount2]-'0'+t;
            t = iSum[j]/10;
            iCount2--;
            j++;
        }
        for (g=j-1; g>=0; g--)
        {
            printf ("%d", iSum[g]);
        }
        printf ("\n");
        if (i+1!=T)
            printf ("\n");
    }
    return 0;
}
/*------------------------
2
1 2
Case 1:
1 + 2 = 3

112233445566778899 998877665544332211
Case 2:
112233445566778899 + 998877665544332211 = 111111111111111110
Press any key to continue...
----------------------*/


 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值