杭电OJ 1002 A + B Problem II

                                      A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 464212    Accepted Submission(s): 89876

Problem Description

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input

2
1 2
112233445566778899 998877665544332211

Sample Output

Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

Author

Ignatius.L


#include<iostream>
using namespace std;
int main()
{
	int nCase,i;
	string a[21],b[21],ret,A,B,T;
	scanf("%d",&nCase);
	for(i=1;i<=nCase;i++)
	{
		cin>>a[i]>>b[i];
    }
    int count=1;
	while(count<=nCase)
	{
		ret="";
		A=a[count];
		B=b[count];
		int aLen,bLen,maxLen;
		aLen=A.size();
		bLen=B.size();
		if(aLen>bLen)
		{
		    maxLen=aLen;
			T.resize(aLen-bLen,'0');
			B=T+B;
		}
		else
		{
			maxLen=bLen;
			T.resize(bLen-aLen,'0');
			A=T+A;
		}
		int temp=0;
		ret.resize(maxLen,'0');
		for(i=maxLen-1;i>=0;i--)
		{
			int nt;
			nt=(A[i]-'0')+(B[i]-'0')+temp;
			ret[i]=(nt%10)+'0';
			temp=nt/10;
		}
		if(temp==1)
		{
			ret="1"+ret;
		}
		for(i=0;i<maxLen;i++)
		{
			if(ret[i]!='0')
			{
				break;
			}
		}
		ret=ret.substr(i);
		if(maxLen==0)
		{
			ret="0";
		}
		printf("Case %d:\n",count);
		cout<<a[count]<<" + "<<b[count]<<" = "<<ret<<endl;
		if(count<nCase)
		printf("\n");
		count++;
    }
	return 0;
 } 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值