HDU 1312 Red and Black 解题报告


Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles. 

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself). 

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13

             原本写的代码太繁琐了,于是重铸了一份,已在NBUToj上提交取得AC。

        DFS基础题。只走黑色的格子,一个格子可以走多次。求有多少个黑色格子可以走到。只需使用DFS搜索,看看有多少格子可以搜索到即可。vis数组表示格子是否已经被搜索到。当然用BFS也可。注意起始点也是一个黑色格子,不要遗漏。


#include <iostream>
#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;

int ans,x,y;
int vis[25][25];
char m[25][25];
int dir[4][2]={0,1,0,-1,1,0,-1,0};

int BFS(int x1,int y1)
{
    int nx,ny;
    for(int i=0;i<4;i++)
    {
        nx=x1+dir[i][0];
        ny=y1+dir[i][1];
        if(nx<0||nx>=x||ny<0||ny>=y)
            continue;
        if(m[nx][ny]!='#'&&!vis[nx][ny])
        {
            vis[nx][ny]=1;
            ans++;
            BFS(nx,ny);
        }
    }
    return 0;
}

int main()
{
    while(~scanf("%d%d",&y,&x)&&x&&y)
    {
        int sti=0,stj=0;
        ans=1;
        memset(vis, 0, sizeof(vis));
        getchar();
        for(int i=0;i<x;i++)
        {
            for(int j=0;j<y;j++)
            {
                scanf("%c",&m[i][j]);
                if(m[i][j]=='@')
                    sti=i,stj=j;
            }
            getchar();
        }
        vis[sti][stj]=1;
        BFS(sti, stj);
        printf("%d\n",ans);
    }
    return 0;
}








  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值