hdu 1312 Red and Black 解题报告

Red and Black

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7843 Accepted Submission(s): 4921


Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)

Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input
  
  
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0

Sample Output
  
  
45 59 6 13

题目大意:告诉你矩阵的宽和高,#代表黑砖,.代表红砖,@代表此人的当前位置,题目告诉这个人只能踩在在他现在的位置的上下左右四个位置,且要是红砖。求此人通过移动能踩到的红砖个数,注意:这里的个数包含此人最开始所在的那个位置。

题目解析:

DFS

解题代码:

#include <iostream>
#include <stdio.h>
#include <cstring>
using namespace std;
int w,h,count;
char map[25][25];
int d[4][2]= {0,-1,0,1,-1,0,1,0};
void dfs(int x,int y)
{
    if(x>=0 && x<h && y>=0 && y<w && map[x][y]!='#')
    {
        count++;
        map[x][y]='#';
        for(int i=0; i<4; i++)
        {
            int nx=x+d[i][0];
            int ny=y+d[i][1];
            dfs(nx,ny);
        }
    }
    else return;
}
int main()
{
    while(1)
    {
        count=0;
        scanf("%d%d",&w,&h);
        if(w==0 && h==0)
            return 0;
        for(int i=0; i<h; i++)
            scanf("%s",map[i]);
        for(int i=0; i<h; i++)
            for(int j=0; j<w; j++)
            {
                if(map[i][j]=='@')
                {
                    dfs(i,j);
                    break;
                }
            }
        printf("%d\n",count);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值