uva 12096 The SetStack Computer 解题报告


Background from Wikipedia: Set theory is a branch of mathematics created principally by the German mathematician Georg Cantor at the end of the 19th century. Initially controversial, set theory has come to play the role of a foundational theory in modern mathematics, in the sense of a theory invoked to justify assumptions made in mathematics concerning the existence of mathematical objects (such as numbers or functions) and their properties. Formal versions of set theory also have a foundational role to play as specifying a theoretical ideal of mathematical rigor in proofs.

Given this importance of sets, being the basis of mathematics, a set of eccentric theorist set off to construct a supercomputer operating on sets instead of numbers. The initial SetStack Alpha is under construction, and they need you to simulate it in order to verify the operation of the prototype.

The computer operates on a single stack of sets, which is initially empty. After each operation, the cardinality of the topmost set on the stack is output. The cardinality of a set S is denoted |S| and is the number of elements in S. The instruction set of the SetStack Alpha is PUSHDUPUNIONINTERSECT, and ADD}.

  • PUSH will push the empty set {} on the stack.
  • DUP will duplicate the topmost set (pop the stack, and then push that set on the stack twice).
  • UNION will pop the stack twice and then push the union of the two sets on the stack.
  • INTERSECT will pop the stack twice and then push the intersection of the two sets on the stack.
  • ADD will pop the stack twice, add the first set to the second one, and then push the resulting set on the stack.

For illustration purposes, assume that the topmost element of the stack is

A = { {}, {{}} },

and that the next one is

B = { {}, {{{}}} }.

For these sets, we have |A| = 2 and |B| = 2. Then:

  • UNION would result in the set { {}, {{}}, {{{}}} }. The output is 3.
  • INTERSECT would result in the set { {} }. The output is 1.
  • ADD would result in the set { {}, {{{}}}, {{},{{}}} }. The output is 3.

Input

An integer 0 ≤ T ≤ 5 on the first line gives the cardinality of the set of test cases. The first line of each test case contains the number of operations 0 ≤ N ≤ 2000. Then follow N lines each containing one of the five commands. It is guaranteed that the SetStack computer can execute all the commands in the sequence without ever popping an empty stack.

Output

For each operation specified in the input, there will be one line of output consisting of a single integer. This integer is the cardinality of the topmost element of the stack after the corresponding command has executed. After each test case there will be a line with *** (three asterisks).

Sample Input

2
9
PUSH
DUP
ADD
PUSH
ADD
DUP
ADD
DUP
UNION
5
PUSH
PUSH
ADD
PUSH
INTERSECT

Sample Output

0
0
1
0
1
1
2
2
2
***
0
0
1
0
0
***
The 2006 ACM Northwestern European Programming Contest



入门经典上STL部分的例题,很好的基础练习题。用到了vector,set,map,stack的知识。

宏的部分不懂,书上说可以先理解为类似函数的东西,那就先搁置这点吧。。。其实我就是懒= =

将集合set用数字int表示,构造一个stack栈,难度在STL的使用,算法本身没多少难度

看懂例程后,自己写了一遍,加了些注释




#include <iostream>
#include <algorithm>
#include <string>
#include <vector>
#include <set>
#include <map>
#include <stack>
using namespace std;

typedef set<int> Set;//用Set表示set<int>
map<Set,int> IDcode;//Set指向int
vector<Set> str;
/*不定长数组存储Set,
 数组元素的序号即为该Set在map中对应的int,
 要注意此题数组中不要将一个Set存储多次*/

#define ALL(x) x.begin(),x.end()
#define INS(x) inserter(x,x.begin())
/*宏,不是很懂,
 书上说可以先理解为类似函数的东西,
 先搁置此点*/

int ID(Set s)
{
    if(IDcode.count(s))
        return IDcode[s];
    /*
     如果map中无s关键字,则说明之前s是新出现的Set
     将新set,即s,存入不定长数组末端,其在数组中的序号将是唯一的
     */
    str.push_back(s);
    return IDcode[s]=(int)str.size()-1;
    //既在map中添加一个关键字的映射,然后将其映射的int值作为返回值
}

int main()
{
    int t;
    cin >> t;
    for(int i=0;i<t;i++)
    {
        int n;
        cin >> n;
        string o;
        stack<int> z;
        //用int表示Set,所以栈的类型为int
        for(int i=0;i<n;i++)
        {
            cin >> o;
            if(o[0]=='P')
            {
                z.push(ID(Set()));
                //Set()表示一个空集
            }
            else if (o[0]=='D')
            {
                z.push(z.top());
            }
            else
            {
                Set x1=str[z.top()];
                z.pop();
                Set x2=str[z.top()];
                z.pop();
                Set x;
                if(o[0]=='U')
                {
                    set_union(ALL(x1),ALL(x2),INS(x));
                    //取并集
                }
                else if (o[0]=='I')
                {
                    set_intersection(ALL(x1),ALL(x2),INS(x));
                    //取交集
                }
                else if (o[0]=='A')
                {
                    x=x2;
                    x.insert(ID(x1));
                    /*
                     set不存储重复的元素,
                     所以insert的元素如果set中已有,
                     则不会重复添加
                     */
                }
                z.push(ID(x));
                //既确定了ID值,又把ID值导入vector中
            }
            cout << str[z.top()].size() << endl;
            //endl表示换行,类似于"\n"
        }
        cout << "***" << endl;
    }
    return 0;
}









  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值