第五章 - The SetStack Computer - uva - 12096

Background from Wikipedia: “Set theory is abranch of mathematics created principally by theGerman mathematician Georg Cantor at the end ofthe 19th century. Initially controversial, set theoryhas come to play the role of a foundational theoryin modern mathematics, in the sense of a theoryinvoked to justify assumptions made in mathematicsconcerning the existence of mathematical objects(such as numbers or functions) and their properties.Formal versions of set theory also have a foundationalrole to play as specifying a theoretical idealof mathematical rigor in proofs.”Given this importance of sets, being the basis of mathematics, a set of eccentric theorist set off toconstruct a supercomputer operating on sets instead of numbers. The initial SetStack Alpha is underconstruction, and they need you to simulate it in order to verify the operation of the prototype.The computer operates on a single stack of sets, which is initially empty. After each operation, thecardinality of the topmost set on the stack is output. The cardinality of a set S is denoted |S| and is thenumber of elements in S. The instruction set of the SetStack Alpha is PUSH, DUP, UNION, INTERSECT,and ADD.• PUSH will push the empty set {} on the stack.• DUP will duplicate the topmost set (pop the stack, and then push that set on the stack twice).• UNION will pop the stack twice and then push the union of the two sets on the stack.• INTERSECT will pop the stack twice and then push the intersection of the two sets on the stack.• ADD will pop the stack twice, add the first set to the second one, and then push the resulting seton the stack.For illustration purposes, assume that the topmost element of the stack isA = {{}, {{}}}and that the next one isB = {{}, {{{}}}}For these sets, we have |A| = 2 and |B| = 2. Then:• UNION would result in the set {{}, {{}}, {{{}}}}. The output is 3.• INTERSECT would result in the set {{}}. The output is 1.• ADD would result in the set {{}, {{{}}}, {{},{{}}}}. The output is 3.InputAn integer 0 ≤ T ≤ 5 on the first line gives the cardinality of the set of test cases. The first line of eachtest case contains the number of operations 0 ≤ N ≤ 2000. Then follow N lines each containing one ofthe five commands. It is guaranteed that the SetStack computer can execute all the commands in thesequence without ever popping an empty stack.OutputFor each operation specified in the input, there will be one line of output consisting of a single integer.This integer is the cardinality of the topmost element of the stack after the corresponding commandhas executed. After each test case there will be a line with ‘***’ (three asterisks).Sample Input29PUSHDUPADDPUSHADDDUPADDDUPUNION5PUSHPUSHADDPUSHINTERSECTSample Output001011222***00100***

#include<iostream>
#include<cstdio>
#include<stack>
#include<set>
#include<map>
#include<vector>
#include<algorithm>
using namespace std;
typedef set<int> Set;
map<Set,int> IDcache;//把集合映像成id
vector<Set> Setcache;//根据id取集合
stack<int> s;

int ID(Set x){
    if(IDcache.count(x)) return IDcache[x];
    Setcache.push_back(x);
    return IDcache[x]=Setcache.size()-1;
}
#define ALL(x) x.begin(),x.end()
#define INS(x) inserter(x,x.begin())
int main(){
    int t,n;
    cin>>t;
    while(t--){
        cin>>n;
        for(int i=0;i<n;i++){
            string op;
            cin>>op;
            if(op[0]=='P')s.push(ID(Set()));
            else if(op[0]=='D')s.push(s.top());
            else{
                Set x1=Setcache[s.top()];s.pop();
                Set x2=Setcache[s.top()];s.pop();
                Set x;
                if(op[0]=='U') set_union(ALL(x1),ALL(x2),INS(x));
                if(op[0]=='I') set_intersection(ALL(x1),ALL(x2),INS(x));
                if(op[0]=='A'){x=x2;x.insert(ID(x1));}
                s.push(ID(x));
            }
            cout<<Setcache[s.top()].size()<<endl;
        }
        cout<<"***"<<endl;
    }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值