Debian9 full the role

debian9更新163源、配置中文输入


更新源并更新fcitx

打开配置文件:

gedit /etc/apt/sources.list

degian9的163源如下:

deb http://mirrors.163.com/debian/ stretch main non-free contrib
deb http://mirrors.163.com/debian/ stretch-updates main non-free contrib
deb http://mirrors.163.com/debian/ stretch-backports main non-free contrib
deb-src http://mirrors.163.com/debian/ stretch main non-free contrib
deb-src http://mirrors.163.com/debian/ stretch-updates main non-free contrib
deb-src http://mirrors.163.com/debian/ stretch-backports main non-free contrib
deb http://mirrors.163.com/debian-security/ stretch/updates main non-free contrib
deb-src http://mirrors.163.com/debian-security/ stretch/updates main non-free contrib

直接ctrl+c ctrl+v后保存即可

同步到本地

apt-get update

root@hostpy:~# apt update
忽略:1 http://mirrors.163.com/debian stretch InRelease
命中:2 http://mirrors.163.com/debian stretch-updates InRelease
命中:3 http://mirrors.163.com/debian stretch-backports InRelease
命中:4 http://mirrors.163.com/debian-security stretch/updates InRelease
命中:5 http://mirrors.163.com/debian stretch Release
错误:2 http://mirrors.163.com/debian stretch-updates InRelease
  由于没有公钥,无法验证下列签名: NO_PUBKEY 8B48AD6246925553 NO_PUBKEY 7638D0442B90D010
错误:3 http://mirrors.163.com/debian stretch-backports InRelease
  由于没有公钥,无法验证下列签名: NO_PUBKEY 8B48AD6246925553 NO_PUBKEY 7638D0442B90D010
错误:4 http://mirrors.163.com/debian-security stretch/updates InRelease
  由于没有公钥,无法验证下列签名: NO_PUBKEY 9D6D8F6BC857C906 NO_PUBKEY 8B48AD6246925553
错误:6 http://mirrors.163.com/debian stretch Release.gpg
  由于没有公钥,无法验证下列签名: NO_PUBKEY 8B48AD6246925553 NO_PUBKEY 7638D0442B90D010 NO_PUBKEY EF0F382A1A7B6500
正在读取软件包列表... 完成  
正在分析软件包的依赖关系树       
正在读取状态信息... 完成       
所有软件包均为最新。
W: 校验数字签名时出错。此仓库未被更新,所以仍然使用此前的索引文件。GPG 错误:http://mirrors.163.com/debian stretch-updates InRelease: 由于没有公钥,无法验证下列签名: NO_PUBKEY 8B48AD6246925553 NO_PUBKEY 7638D0442B90D010
W: 校验数字签名时出错。此仓库未被更新,所以仍然使用此前的索引文件。GPG 错误:http://mirrors.163.com/debian stretch-backports InRelease: 由于没有公钥,无法验证下列签名: NO_PUBKEY 8B48AD6246925553 NO_PUBKEY 7638D0442B90D010
W: 校验数字签名时出错。此仓库未被更新,所以仍然使用此前的索引文件。GPG 错误:http://mirrors.163.com/debian-security stretch/updates InRelease: 由于没有公钥,无法验证下列签名: NO_PUBKEY 9D6D8F6BC857C906 NO_PUBKEY 8B48AD6246925553
W: 校验数字签名时出错。此仓库未被更新,所以仍然使用此前的索引文件。GPG 错误:http://mirrors.163.com/debian stretch Release: 由于没有公钥,无法验证下列签名: NO_PUBKEY 8B48AD6246925553 NO_PUBKEY 7638D0442B90D010 NO_PUBKEY EF0F382A1A7B6500
W: 无法下载 http://mirrors.163.com/debian/dists/stretch-updates/InRelease  由于没有公钥,无法验证下列签名: NO_PUBKEY 8B48AD6246925553 NO_PUBKEY 7638D0442B90D010
W: 无法下载 http://mirrors.163.com/debian/dists/stretch-backports/InRelease  由于没有公钥,无法验证下列签名: NO_PUBKEY 8B48AD6246925553 NO_PUBKEY 7638D0442B90D010
W: 无法下载 http://mirrors.163.com/debian-security/dists/stretch/updates/InRelease  由于没有公钥,无法验证下列签名: NO_PUBKEY 9D6D8F6BC857C906 NO_PUBKEY 8B48AD6246925553
W: 无法下载 http://mirrors.163.com/debian/dists/stretch/Release.gpg  由于没有公钥,无法验证下列签名: NO_PUBKEY 8B48AD6246925553 NO_PUBKEY 7638D0442B90D010 NO_PUBKEY EF0F382A1A7B6500
W: 部分索引文件下载失败。如果忽略它们,那将转而使用旧的索引文件。



(3)如果出现GPG error的时候,可以将NO_PUBLICKEY 后面所接的public_key如下:
gpg --keyserver pgpkeys.mit.edu --recv-key  xxx  
gpg -a --export xxx| sudo apt-key add -
注:其中的xxx为在apt-get update的时候提示的no_publickey后面所对应的key

gpg --keyserver pgpkeys.mit.edu --recv-key 8B48AD6246925553 7638D0442B90D010

root@hostpy:~# gpg --keyserver pgpkeys.mit.edu --recv-key 8B48AD6246925553 7638D0442B90D010
gpg: directory '/root/.gnupg' created
gpg: keybox '/root/.gnupg/pubring.kbx' created
gpg: /root/.gnupg/trustdb.gpg: trustdb created
gpg: key 7638D0442B90D010: public key "Debian Archive Automatic Signing Key (8/jessie) <ftpmaster@debian.org>" imported
gpg: key 8B48AD6246925553: public key "Debian Archive Automatic Signing Key (7.0/wheezy) <ftpmaster@debian.org>" imported
gpg: no ultimately trusted keys found
gpg: Total number processed: 2
gpg:               imported: 2

gpg -a --export 8B48AD6246925553 7638D0442B90D010 | apt-key add -

????

gpg --keyserver pgpkeys.mit.edu --recv-key




解决中文输入法不可用的问题

你输入的时候各种ctrl+space或者ctrl+shift一通乱按就是什么也看不到?因为根本就没有Ui控件…
你需要安装输入法前端所需的ui动态库

apt-get install fcitx-ui-classic && apt-get install fcitx-ui-light

安装完,打开fcitx的配置工具,根据需要删掉不需要的输入法。我就留了一个键盘英语和google输入法。有肯能还是不行,那就重启一下。

reboot




gpg -a --export

阅读更多
想对作者说点什么?

博主推荐

换一批

没有更多推荐了,返回首页