Diophantus of Alexandria

Diophantus of Alexandria was an egypt mathematician living in Alexandria. He was one of the first mathematicians to study equations where variables were restricted to integral values. In honor of him, these equations are commonly called diophantine equations. One of the most famous diophantine equation is x^n + y^n = z^n. Fermat suggested that for n > 2, there are no solutions with positive integral values for x, y and z. A proof of this theorem (called Fermat's last theorem) was found only recently by Andrew Wiles. 

Consider the following diophantine equation: 

1 / x + 1 / y = 1 / n where x, y, n ∈ N+ (1)



Diophantus is interested in the following question: for a given n, how many distinct solutions (i. e., solutions satisfying x ≤ y) does equation (1) have? For example, for n = 4, there are exactly three distinct solutions: 

1 / 5 + 1 / 20 = 1 / 4 
1 / 6 + 1 / 12 = 1 / 4 
1 / 8 + 1 / 8 = 1 / 4




Clearly, enumerating these solutions can become tedious for bigger values of n. Can you help Diophantus compute the number of distinct solutions for big values of n quickly? 

Input

The first line contains the number of scenarios. Each scenario consists of one line containing a single number n (1 ≤ n ≤ 10^9). 

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Next, print a single line with the number of distinct solutions of equation (1) for the given value of n. Terminate each scenario with a blank line. 

Sample Input

2
4
1260

Sample Output

Scenario #1:
3

Scenario #2:
113

代码:

#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
using namespace std;
#define M 50005
int  prime[50005];
void db()
{
    int i,j;
    memset(prime,0,sizeof(prime));
    for(i=2; i<=M; i++)
    {   
        if(prime[i]==0)
        {
            for(j=i+i; j<=M; j+=i)
            {
                 prime[j]=1;
            }
        }
    }
}
int main()
{

    db();
    int n,i,j,k,t;
    scanf("%d",&t);
    int sum;
    int cnt=1;
    while(t--)
    {
        sum=1;
       
        scanf("%d",&n);
        for(i=2; i<=M; i++)
        {
            if(n==1)
            break;
            if(prime[i]==0)
            {
                    k=0;
                    while(n%i==0)
                    {
                        k++;
                        n=n/i;
                    }
                    sum=sum*(2*k+1);
            }
        }

        if(n>1)
            sum=sum*3;
        printf("Scenario #%d:\n",cnt);
        printf("%d\n\n",(sum+1)/2);
        cnt++;

    }
    return 0;

}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

black-hole6

你的鼓励将是我创作的动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值