Anniversary party (树形DP)

There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings. 

Input

Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go T lines that describe a supervisor relation tree. Each line of the tree specification has the form: 
L K 
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line 
0 0

Output

Output should contain the maximal sum of guests' ratings. 

Sample Input

7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0

Sample Output

5

题解:这个题意是要举行晚会,每个人邀请了1——N个人,然后,每个人都有一个愉快值,但是如果每个人如果他的直接上司在他就会不开心,既然有等级关系,我们可以建立一棵树,然后对这棵树进行比较,通过dfs遍历,我们可以把在当前深度和他的上司深度进行比较,择优选择较大,这是一个dp的过程并且是在树上的操作,故可以用树形dp来解。,然后存图问题需要考虑,

下面给出两种代码,一种过poj,过不了hdu,另一种可过hdu

代码:

过POJ:

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>

using namespace std;

int pre[6005],vis[6005],n,dp[6005][2],s[6005];
void dfs(int a)
{
    vis[a]=1;
    for(int i=1; i<=n; i++)
    {
        if(vis[i]==0&&pre[i]==a)
        {
            dfs(i);
            dp[a][0]+=max(dp[i][0],dp[i][1]);
            dp[a][1]+=dp[i][0];
        }
    }
    return;
}
int main()
{       
        while(scanf("%d",&n)!=EOF)
        {
		
        int a,b;
        memset(vis,0,sizeof(vis));
        memset(s,0,sizeof(s));
        for(int t=1; t<=n; t++)
        {
            scanf("%d",&dp[t][1]);
            dp[t][0]=0;
        }
        while(scanf("%d%d",&a,&b))
        {
        	if(a==0||b==0)//注意是||,不然会TLE 
        	break;
            pre[a]=b;
            s[a]=1;
        }
        for(int t=1; t<=n; t++)
            if(!s[t])
			{
			a=t;
			}
        dfs(a);
        printf("%d\n",max(dp[a][0],dp[a][1]));
        }
    return 0;
}

可过HDU

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<vector>

using namespace std;

vector<int>v[6005];
int pre[6005];
int s[6005];
int dp[6005][2];

void dfs(int root)
{
    int len=v[root].size();
    dp[root][1]=s[root];
    for(int i=0;i<len;i++)
       dfs(v[root][i]);
    for(int i=0;i<len;i++)
    {
        dp[root][0]+=max(dp[v[root][i]][1],dp[v[root][i]][0]);
        dp[root][1]+=dp[v[root][i]][0];
    }
}
int main()
{
    int n;
    int a,b;
    while(scanf("%d",&n)!=EOF)
    {
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&s[i]);
            v[i].clear();
            pre[i]=-1;//对树根标记 
            dp[i][0]=dp[i][1]=0;
        }
        while(scanf("%d%d",&a,&b))
        {
            if(a==0&&b==0)break;
            pre[a]=b;
            v[b].push_back(a);
        }
        a=1;
        while(pre[a]!=-1)
		a=pre[a];//找树根
        dfs(a);
        printf("%d\n",max(dp[a][1],dp[a][0]));
    }
    return 0;
}

 

  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

black-hole6

你的鼓励将是我创作的动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值