Anniversary party [树形dp]

There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests’ conviviality ratings.
Input

Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go N – 1 lines that describe a supervisor relation tree. Each line of the tree specification has the form:
L K
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line
0 0
Output

Output should contain the maximal sum of guests’ ratings.
Sample Input

7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0
Sample Output

5
Source

Ural State University Internal Contest October’2000 Students Session

树形DP,即是在一颗树上进行DP,一般是有叶子节点状态推出根节点状态。
【题意】

公司有n个人,每个人有价值vi,有一天举办年会,每个人都可以参加,但有严格的等级制度,参加活动时,不能同时出现a和a的上司,问如何才能使总和最大。

【分析】

每个人只有去和不去两种状态,设DP[i][0]和DP[i][1]分别表示第i个人不参加和参加年会,获得的总的最大价值。

则状态转移方程为:

DP[i][1] += DP[j][0],

DP[i][0] += max{DP[j][0],DP[j][1]};其中j为i的孩子节点。

这样,从根节点r进行dfs,最后结果为max{DP[r][0],DP[r][1]}。

#include<bits/stdc++.h>

using namespace std;

const int MAXN = 6500;

int dp[MAXN][2];
vector <int> tree[MAXN];
int vis[MAXN];

int DFS(int root) {
    vis[root] = 1;
    for (int i = 0; i < (int)tree[root].size(); i++) {
        int v = tree[root][i];
        if (!vis[v]) {
            DFS(v);
            dp[root][0] += max(dp[v][0], dp[v][1]);
            dp[root][1] += dp[v][0];
        }
    }
}

int main() {
    int n;
    while (scanf ("%d", &n) != EOF) {
        for (int i = 0; i <= n; i++)
            tree[i].clear();
        memset(vis, 0, sizeof(vis));
        for (int i = 1; i <= n; i++) {
            cin >> dp[i][1];
            dp[i][0] = 0;
        }
        int fa, so;
        while (scanf ("%d %d", &fa, &so) != EOF) {
            if (fa == 0 && so == 0) break;
            tree[fa].push_back(so);
            tree[so].push_back(fa);
        }
        DFS(1);
        cout << max(dp[1][0], dp[1][1]) << endl;
    }
    return 0;
}
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <vector>
using namespace std;
const int maxn = 6050;
int fa[maxn],dp[maxn][2],vis[maxn]; //dp[i][0]表示第i个人参加了聚会,dp[i][1]表示第i个人没有参加聚会
vector <int> vec[maxn];   //利用vector数组来存父节点的所有子节点
int n;

void Find(int root)
{
    vis[root] = 1;
    for(int i = 0; i < vec[root].size(); i++)
    {
        int temp = vec[root][i];
        if(!vis[temp])
        {
            Find(temp);
            dp[root][0] += max(dp[temp][0],dp[temp][1]);   //如果这个人没有参加
            //,那么就可以从下属参加或者不参加中2个情况中选较大值
            dp[root][1] += dp[temp][0]; //这个人你参加了聚会,所以下属一定不能参加聚会了。
        }
    }
}

int main()
{
    while(scanf("%d", &n) != EOF)
    {
        memset(dp,0,sizeof(dp));
        memset(fa,0,sizeof(fa));
        memset(vis,0,sizeof(vis));
        for(int i = 1; i <= n; i++)
        {
            scanf("%d",&dp[i][1]);
            vec[i].clear();
        }
        int x,y;
        int root = 0;
        while(scanf("%d%d",&x,&y) != EOF && (x||y))
        {
            vec[y].push_back(x);
            fa[x] = y;
            if(!root) root = y;
        }
        while(fa[root])         //这里需要注意利用fa[]数组来找到根节点。
            root = fa[root];
        Find(root);
        printf("%d\n",max(dp[root][0],dp[root][1]));
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值