hdoj 1711Number Sequence (简单KMP匹配)

Number Sequence

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8710    Accepted Submission(s): 4008


Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
 

Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
 

Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
 

Sample Input
  
  
2 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 1 3 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 2 1
 

Sample Output
  
  
6 -1
 

Source
 

Recommend
lcy


超简单的KMP匹配题。

#include<stdio.h>


int ArrN[1000005],ArrM[10005];
int N,M;
int next[10005];


void Get_next()
{
    int j=0;
    int k=-1;
    next[0]=-1;
    while(j<M)
    {
        if(-1==k || ArrM[j]==ArrM[k])
        {
            ++j;
            ++k;
            if(ArrM[j]!=ArrM[k])
                next[j]=k;
            else
                next[j]=next[k];
        }
        else
            k=next[k];
    }
}//end Get_next() O(n)


int KMP_Match()
{
    int i=0;
    int j=0;
    Get_next();
    while(i<N && j<M)
    {
        if(ArrN[i]==ArrM[j] || -1==j)
        {
            ++i;
            ++j;
        }
        else
            j=next[j];
    }
    if(j==M)
        return (i-j);
    else
        return -1;
}


int main()
{
    int Case;
    int ans=0;
    scanf("%d", &Case);
    while(Case--)
    {
        int i;
        scanf("%d%d",&N,&M);
        for(i=0; i<N; ++i)
            scanf("%d",&ArrN[i]);
        for(i=0; i<M; ++i)
            scanf("%d",&ArrM[i]);
        ans=KMP_Match();
        if(-1==ans)
            printf("-1\n");
        else
            printf("%d\n",ans+1);
    }
    return 0;


}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值