uva414 机器表面

 Machined Surfaces 

An imaging device furnishes digital images of two machined surfaces that eventually will be assembled in contact with each other. The roughness of this final contact is to be estimated.

A digital image is composed of the two characters, "X" and " " (space). There are always 25 columns to an image, but the number of rows, N, is variable. Column one (1) will always have an "X" in it and will be part of the left surface. The left surface can extend to the right from column one (1) as contiguous X's.

Similarly, column 25 will always have an "X" in it and will be part of the right surface. The right surface can extend to the left from column 25 as contiguous X's.

Digital-Image View of Surfaces

 
		 Left     		                           Right

XXXX XXXXX tex2html_wrap_inline50

XXX XXXXXXX

XXXXX XXXX

XX XXXXXX

. .

. .

. .

XXXX XXXX

XXX XXXXXX tex2html_wrap_inline52

tex2html_wrap_inline54 tex2html_wrap_inline56

1 25

In each row of the image, there can be zero or more space characters separating the left surface from the right surface. There will never be more than a single blank region in any row.

For each image given, you are to determine the total ``void" that will exist after the left surface has been brought into contact with the right surface. The ``void" is the total count of the spaces that remains between the left and right surfaces after theyhave been brought into contact.

The two surfaces are brought into contact by displacing them strictly horizontally towards each other until a rightmost "X" of the left surface of some row is immediately to the left of the leftmost "X" of the right surface of that row. There is no rotation or twisting of these two surfaces as they are brought into contact; they remain rigid, and only move horizontally.

Note: The original image may show the two surfaces already in contact, in which case no displacement enters into the contact roughness estimation.

Input

The input consists of a series of digital images. Each image data set has the following format:

First line -
A single unsigned integer,  N, with value greater than zero (0) and less than 13. The first digit of  Nwill be the first character on a line.

Next N lines -
Each line has exactly 25 characters; one or more  X's, then zero or more spaces, then one or more  X's.

The end of data is signaled by a null data set having a zero on the first line of an image data set and no further data.

Output

For each image you receive as a data set, you are to reply with the total void (count of spaces remaining after the surfaces are brought into contact). Use the default output for a single integer on a line.

Sample Input (character "B" for ease of reading. The actual input file will use the ASCII-space character, not "B").

4
XXXXBBBBBBBBBBBBBBBBXXXXX
XXXBBBBBBBBBBBBBBBXXXXXXX
XXXXXBBBBBBBBBBBBBBBBXXXX
XXBBBBBBBBBBBBBBBBBXXXXXX
2
XXXXXXXXXXXXXXXXXXXXXXXXX
XXXXXXXXXXXXXXXXXXXXXXXXX
1
XXXXXXXXXBBBBBBBBBBBBBBXX
0

Sample Output

4
0
0
 
 
 
又是一道简单题,浪费了我40分钟才AC。。。
首先是英语的问题,看来我英语水平依旧很差,看着题目看了半天才了解题意。
然后,较快速度写出了一份代码,却死活WA,看了看原来是看题漏掉了一句话:character "B" for ease of reading. The actual input file will use the ASCII-space character, not "B"。
泥煤啊,原来不是B啊,是空格啊我擦。。。
之后,不能用scanf了,要用可恶的gets。(我一直用C++编译,但是用C语言的标准输入输出,这是因为C语言标准IO更节约时间,而C++太方便了,不用是损失啊)
gets()会吃掉最开始输入N的‘\n’,自动记为一行,这点差点又忘了。。。
 
好了,题目大意如下:输入的图表示两个待接合在一起的机器表面,计算把他们结合在一起以后还有多少个空格。
算法思维很简单,从上到下计算每一行的空格数cnt[i],空格数最小(空格数min_blank)的哪一行可以成功接合,其他行接合后还多出了cnt[i]-blank个空格。
#include <cstdio>
#include <cctype>
#include <cstring>
using namespace std;

const int INF=0xFFFFFF;
char surface[15][26];//记录图像
int cnt[15];//记录每行空格数

int main()
{
	int n;
	while(scanf("%d",&n)!=EOF){
		getchar();//吃掉scanf的换行符,以免影响gets
		if(n<1||n>13)
			break;
		int min_blank=INF;
		memset(cnt,0,sizeof(cnt));
		for(int i=0;i<n;i++)
			gets(surface[i]);//其实最好用fgets(surface[i],26,stdin),偷懒了
		for(int i=0;i<n;i++){
			for(int j=0;j<25;j++)
				if(surface[i][j]==' ')
					cnt[i]++;
			if(cnt[i]<min_blank)
				min_blank=cnt[i];//最小空格数
		}
		int sum=0;
		for(int i=0;i<n;i++){
			sum+=cnt[i]-min_blank;
		}
		printf("%d\n",sum);
	}
	return 0;
}

水平依旧很差,到底还有多久才能变强?
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值