POJ 1493 Machined Surfaces(我的水题之路——移动后的空格)

Machined Surfaces
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 1712 Accepted: 1123

Description

An imaging device furnishes digital images of two machined surfaces that eventually will be assembled in contact with each other. The roughness of this final contact is to be estimated. 


A digital image is composed of the two characters, "X" and " " (space). There are always 25 columns to an image, but the number of rows, N, is variable. Column one (1) will always have an "X" in it and will be part of the left surface. The left surface can extend to the right from column one (1) as contiguous X's. 


Similarly, column 25 will always have an "X" in it and will be part of the right surface. The right surface can extend to the left from column 25 as contiguous X's. 

Digital-Image View of Surfaces 
		 Left  		                           Right



		 XXXX                                      XXXXX  ←1

		 XXX                                     XXXXXXX

		 XXXXX                                      XXXX

		 XX                                       XXXXXX

		 .                                             .

		 .                                             .

		 .                                             .

		 XXXX                                       XXXX

		 XXX                                       XXXXX  ←N

		↑	       		                   ↑

		1         			  	25


In each row of the image, there can be zero or more space characters separating the left surface from the right surface. There will never be more than a single blank region in any row. 

For each image given, you are to determine the total ``void" that will exist after the left surface has been brought into contact with the right surface. The ``void" is the total count of the spaces that remains between the left and right surfaces after theyhave been brought into contact. 

The two surfaces are brought into contact by displacing them strictly horizontally towards each other until a rightmost "X" of the left surface of some row is immediately to the left of the leftmost "X" of the right surface of that row. There is no rotation or twisting of these two surfaces as they are brought into contact; they remain rigid, and only move horizontally. 

Note: The original image may show the two surfaces already in contact, in which case no displacement enters into the contact roughness estimation. 

Input

The input consists of a series of digital images. Each image data set has the following format: 

First line - 
A single unsigned integer, N, with value greater than zero (0) and less than 13. The first digit of N will be the first character on a line. 

Next N lines - 
Each line has exactly 25 characters; one or more X's, then zero or more spaces, then one or more X's. 

The end of data is signaled by a null data set having a zero on the first line of an image data set and no further data. 

Output

For each image you receive as a data set, you are to reply with the total void (count of spaces remaining after the surfaces are brought into contact). Use the default output for a single integer on a line.

Sample Input

4
XXXX                XXXXX
XXX               XXXXXXX
XXXXX                XXXX
XX                 XXXXXX
2
XXXXXXXXXXXXXXXXXXXXXXXXX
XXXXXXXXXXXXXXXXXXXXXXXXX
1
XXXXXXXXX              XX
0

Sample Output

4
0
0

Source


有一个25列N行的矩阵,每一行有左边X,和右边X两个X部分,中间只有一个空白部分,如果将所有行的左边X部分同时向右边移动,直到其中某一行与该行的右边X相碰,问这个时候,整个图形中左边X与右边X之间的空格数量。

在输入时候,统计每一行空格数目,并且找到最少的那个空格数,然后将每一行的空格数去减去最小空格数得到的差之和,就是解。

代码(1AC):
#include <cstdio>
#include <cstdlib>
#include <cstring>

int space[20];

int main(void){
    int i, j;
    int rows, minrow;
    int remaining;

    while (scanf("%d", &rows), rows != 0){
        memset(space, 0, sizeof(space));
        for (i = 0; i < rows; i++){
            getchar();
            for (j = 0; j < 25; j++){
                if (getchar() == ' '){
                    space[i] ++;
                }
            }
            if (i == 0){
                minrow = space[0];
            }
            else{
                if (minrow > space[i]){
                    minrow = space[i];
                }
            }
        }
        for (remaining = i = 0; i < rows; i++){
            remaining += space[i] - minrow;
        }
        printf("%d\n", remaining);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值