杭电--1018 Big Number

本题链接:点击打开链接

Big Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 37508    Accepted Submission(s): 18024


Problem Description
In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.
 

Input
Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 10 7 on each line.
 

Output
The output contains the number of digits in the factorial of the integers appearing in the input.
 

Sample Input
  
  
2 10 20
 

Sample Output
  
  
7 19
 

Source
 

Recommend
JGShining   |   We have carefully selected several similar problems for you:   1071  1060  1065  1028  1042 
 

题意:先给出一个整数n,表示有n组测试数据,接着是有n个数据,每一个数据都是介于1到107之间。要求的是每个数阶层的位数,也就是每个数字阶层的长度是多少?

解题思路:

1.直接暴力求解,但似乎数据真的实在是太大了,但只要稍微改进一下代码还是可以AC的,只是比较费时,本人用了889MS险过;由于数据比较大,所以得用double类型,有时候这也是一个小技巧。

代码1:

#include <stdio.h>
#include <stdlib.h>
int main()
{
    int t,i,k,n;
    double w;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        s=1;
        w=1;
        for(i=2; i<=n; i++)
        {
            s=s*i;
            if(s>=10)			//每计算一次大于10了,就先计算已有位数,并且在同一个for循环里进行,可节约一点时间。
                while(s>=10)
                {
                    s/=10;
                    w++;		//记录已有位数。
                }
        }
        printf("%d\n",w);
    }
    return 0;
}


2.利用本题特性用数位解答,首先我们的知道一个知识点,那就是 任意一个正整数a的位数等于(int)log10(a) + 1; 对于任意一个给定的正整数a,至于推导大家可以借鉴:(详情点击链接http://www.wendangku.net/doc/b2ca872014791711cd79170b.html

假设10^(x-1)<=a<10^x,那么显然a的位数为x位,又因为
log10(10^(x-1))<=log10(a)<(log10(10^x))
即x-1<=log10(a)<x
则(int)log10(a)=x-1,
即(int)log10(a)+1=x
即a的位数是(int)log10(a)+1;

代码2.

#include <stdio.h>
#include <stdlib.h>
#include <math.h>
int main()
{
    int t,i,n;
    double w;
    scanf("%d",&t);
    while(t--)
    {
            scanf("%d",&n);
            w=1;
            for(i=1;i<=n; i++)
            w=w+log10((double)i);
        printf("%d\n",(int) w);
    }
    return 0;
}

3.最近还发现了一作做法,那就是利用斯特林公式来做,公式是:log10(n!)=1.0/2*log10(2*PI*n)+n*log10(n/e);至于为什么来来的,有兴趣的朋友可以自己去查有关资料,不然记忆就好,和前面的第二种方法一样,有了公式就很简单了。

代码3:

#include <stdio.h>
#include <stdlib.h>
#include <math.h>
#define e 2.71828182
#define PI 3.141592654
int main()
{
    int t;
    int n;
    double w;             //斯特林数
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        w=(1.0/2*log10(2*PI*n)+n*log10(n/e));
        printf("%d\n",(int) w+1);              //记得+1,不能少。
    }
    return 0;
}


以上三种方法我推荐的是第二种和第三种,两个公式大家可以不必细究到底怎么来的,但一定要记住它,关键时刻很有用,希望能帮到一些朋友。

  • 5
    点赞
  • 5
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值