POJ1651

The multiplication puzzle is played with a row of cards, each containing a single positive integer. During the move player takes one card out of the row and scores the number of points equal to the product of the number on the card taken and the numbers on the cards on the left and on the right of it. It is not allowed to take out the first and the last card in the row. After the final move, only two cards are left in the row.

The goal is to take cards in such order as to minimize the total number of scored points.

For example, if cards in the row contain numbers 10 1 50 20 5, player might take a card with 1, then 20 and 50, scoring

10*1*50 + 50*20*5 + 10*50*5 = 500+5000+2500 = 8000


If he would take the cards in the opposite order, i.e. 50, then 20, then 1, the score would be

1*50*20 + 1*20*5 + 10*1*5 = 1000+100+50 = 1150.

Input

The first line of the input contains the number of cards N (3 <= N <= 100). The second line contains N integers in the range from 1 to 100, separated by spaces.

Output

Output must contain a single integer - the minimal score.

Sample Input

6
10 1 50 50 20 5

Sample Output

3650

这题要设置好dp的意义:(之前将dp[i][j]解释为序列[i,j]可以得到的最小值,这样要讨论抽取的牌的情况,做起来是比较繁琐的)

这里dp表示:dp[i][j]表示从序列[i,j]中抽取纸牌最后剩下i和j的最小值,这样讨论抽取的牌时只要乘上i位置和j位置的纸牌就行了

#include<iostream>
#include<string.h>
#include<algorithm>
#include<vector>
#include<queue>
#include<set>
using namespace std;
const int INF = 1<<29;
const int MAX = 110;
int N;
long long card[MAX];
long long dp[MAX][MAX]; //dp[i][j]表示从序列[i,j]中取出的纸牌最后剩下i和j的最小分数值

void solve()
{
    for (int i = 1; i <= N; i++)
        for (int j = 1; j <= N; j++)
            dp[i][j] = INF;

    for (int i = 1; i <= N-2; i++)
        dp[i][i+2] = card[i] * card[i+1] * card[i+2];
    for (int i = 1; i <= N - 1; i++)
    {
        dp[i][i] = 0;
        dp[i][i+1] = 0;
    }

    for (int l = 4; l <= N; l++)    //从序列长度为4开始
    {
        for (int i = 1; i <= N - l + 1; i++)    //序列的范围从1开始
        {
            for (int k = i + 1; k <= i + l - 2; k++)
            {
                dp[i][i+l-1] = min(dp[i][i+l-1], dp[i][k] + card[i] * card[k] * card[i+l-1] + dp[k][i+l-1]);

            }
        }
    }
}

int main()
{
    cin >> N;

    for (int i = 1; i <= N; i++)
        cin >> card[i];

    solve();
    cout << dp[1][N] <<endl;

    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值