CDOJ(UESTC) 1520 string (这贪心厉害了)

string

Time Limit: 3000/1000MS (Java/Others)     Memory Limit: 65535/65535KB (Java/Others)

A string consisting of lowercase letters,two adjacent character can be combined if and only if this two character are different.And the combined character is the latter one. (such as "ac" can be combined, and the result is "a").

Now your work is to combined the character as more as possible so that finally the string can be shortest.

Input

A string consisting of lowercase letters. (1length200000)

Output

a positive integer x means the finally length of string.

Sample input and output

Sample InputSample Output
abcd
1
aac
2


分析:贪心求解,贪心策略:从后向前进行贪心

AC代码:

#include<cstdio>
#include<cstring>
using namespace std;
const int maxn=200000+10;
char s[maxn];
int d[maxn];
int main(){
	while(scanf("%s",s)==1){
		memset(d,0,sizeof(d));
		
		int len=strlen(s);
		d[len-1]=1;
		for(int i=len-2;i>=0;i--){
			if(s[i]==s[i+1])d[i]=d[i+1]+1;
			else d[i]=1;
		}
		
		printf("%d\n",d[0]);
	}
	return 0;
}







  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

柏油

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值