HDU 1841 Find the Shortest Common Superstring(KMP)

Find the Shortest Common Superstring


Problem Description
The shortest common superstring of 2 strings S 1 and S 2 is a string S with the minimum number of characters which contains both S 1 and S 2 as a sequence of consecutive characters. For instance, the shortest common superstring of “alba” and “bacau” is “albacau”.
Given two strings composed of lowercase English characters, find the length of their shortest common superstring.
 

Input
The first line of input contains an integer number T, representing the number of test cases to follow. Each test case consists of 2 lines. The first of these lines contains the string S 1 and the second line contains the string S 2. Both of these strings contain at least 1 and at most 1.000.000 characters.
 

Output
For each of the T test cases, in the order given in the input, print one line containing the length of the shortest common superstring.
 

Sample Input
  
  
2 alba bacau resita mures
 

Sample Output
  
  
7 8

两次KMP;

AC代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn=1e6+10;
char s1[maxn],s2[maxn];
int next1[maxn];

void get_next(char *s){
	next1[0]=0;
	int len=strlen(s);
	int k=0;
	for(int p=1;p<len;p++){
		while(k>0 && s[k]!=s[p])
		k=next1[k-1];
		
		if(s[k]==s[p])k++;
		
		next1[p]=k;
	}
}

int KMP(char *s1,char *s2){
	get_next(s1);
	int l1=strlen(s1);
	int l2=strlen(s2);
	int i=0,j=0;
	while(i<l1 && j<l2){
		if(s1[i]==s2[j]){
			i++;j++;
		}
		
		else if(i==0)j++;
		
		else i=next1[i-1];
	}
	
//和hdu1867几乎一模一样的题,但是1867要加上下面这句,因为要打印字符串,而这里加上就会错!!!!!(两次交换顺序的kmp,应该没影响吧,但是加上就是A不了)
	//if(i<l1 || (i==l1&&j==l2))return i;
	return i;
}
int main(){
	int T;
	scanf("%d",&T);
	while(T--){
		scanf("%s%s",s1,s2);
		
		int l1=KMP(s1,s2);
		int l2=KMP(s2,s1);
		
		int Max=max(l1,l2);
		printf("%d\n",strlen(s1)+strlen(s2)-Max);
	}
	return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

柏油

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值