hdoj1841Find the Shortest Common Superstring【扩展KMP模板】

Find the Shortest Common Superstring

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 1602    Accepted Submission(s): 428


Problem Description
The shortest common superstring of 2 strings S 1  and S 2  is a string S with the minimum number of characters which contains both S 1  and S 2  as a sequence of consecutive characters. For instance, the shortest common superstring of “alba” and “bacau” is “albacau”.
Given two strings composed of lowercase English characters, find the length of their shortest common superstring.  
 

Input
The first line of input contains an integer number T, representing the number of test cases to follow. Each test case consists of 2 lines. The first of these lines contains the string S 1  and the second line contains the string S 2. Both of these strings contain at least 1 and at most 1.000.000 characters.
 

Output
For each of the T test cases, in the order given in the input, print one line containing the length of the shortest common superstring.
 

Sample Input
  
  
2 alba bacau resita mures
 

Sample Output
  
  
7 8
 

Author
Mugurel Ionut Andreica
 
#include<cstdio>
#include<cstdlib>
#include<cstring>
using namespace std;
const int MAX=1000010;
int next[MAX];
int extend[MAX];
int MIN(int a,int b){
	return a<b?a:b;
}
void getNext(char *T){
	int i,lenT=strlen(T);
	next[0]=lenT;
	for(i=0;i<lenT-1&&T[i]==T[i+1];++i);
	next[1]=i;
	int a=1;
	for(int k=2;k<lenT;++k){
		int p=a+next[a]-1,L=next[k-a];
		if((k+L-1)>=p){
			int j=(p-k+1)>0?(p-k+1):0;
			while(k+j<lenT&&T[j]==T[k+j])j++;
			next[k]=j;a=k;
		}
		else {
			next[k]=L;
		}
	}
}
int getExtend(char *S,char *T){
	memset(next,0,sizeof(next));
	getNext(T);
	int lenS=strlen(S),lenT=strlen(T);
	int minLen=MIN(lenS,lenT);
	int a=0;
	while(a<minLen&&S[a]==T[a])a++;
	if(a==minLen)return lenS+lenT-minLen;
	extend[0]=a;a=0;
	for(int k=1;k<=lenS;++k){
		int p=a+extend[a]-1,L=next[k-a];
		if(p==lenS-1)return lenT+a;
		if((k+L-1)>=p){
			int j=(p-k+1)>0?(p-k+1):0;
			while(k+j<lenS&&j<lenT&&S[k+j]==T[j])j++;
			extend[k]=j;a=k;
			if(j==lenT)return lenS;
		}
		else extend[k]=L;
	}
	return lenS+lenT;
}
char str[1000010];
char s[1000010];
int main()
{
	int t;
	scanf("%d",&t);
	getchar();
	while(t--){
		gets(str);
		gets(s);
		printf("%d\n",MIN(getExtend(s,str),getExtend(str,s)));
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值