poj 1265 Area

题目衔接:http://poj.org/problem?id=1265

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 8039 Accepted: 3375

Description

Being well known for its highly innovative products, Merck would definitely be a good target for industrial espionage. To protect its brand-new research and development facility the company has installed the latest system of surveillance robots patrolling the area. These robots move along the walls of the facility and report suspicious observations to the central security office. The only flaw in the system a competitor抯 agent could find is the fact that the robots radio their movements unencrypted. Not being able to find out more, the agent wants to use that information to calculate the exact size of the area occupied by the new facility. It is public knowledge that all the corners of the building are situated on a rectangular grid and that only straight walls are used. Figure 1 shows the course of a robot around an example area.



Figure 1: Example area.


You are hired to write a program that calculates the area occupied by the new facility from the movements of a robot along its walls. You can assume that this area is a polygon with corners on a rectangular grid. However, your boss insists that you use a formula he is so proud to have found somewhere. The formula relates the number I of grid points inside the polygon, the number E of grid points on the edges, and the total area A of the polygon. Unfortunately, you have lost the sheet on which he had written down that simple formula for you, so your first task is to find the formula yourself.

Input

The first line contains the number of scenarios.
For each scenario, you are given the number m, 3 <= m < 100, of movements of the robot in the first line. The following m lines contain pairs 揹x dy�of integers, separated by a single blank, satisfying .-100 <= dx, dy <= 100 and (dx, dy) != (0, 0). Such a pair means that the robot moves on to a grid point dx units to the right and dy units upwards on the grid (with respect to the current position). You can assume that the curve along which the robot moves is closed and that it does not intersect or even touch itself except for the start and end points. The robot moves anti-clockwise around the building, so the area to be calculated lies to the left of the curve. It is known in advance that the whole polygon would fit into a square on the grid with a side length of 100 units.

Output

The output for every scenario begins with a line containing 揝cenario #i:� where i is the number of the scenario starting at 1. Then print a single line containing I, E, and A, the area A rounded to one digit after the decimal point. Separate the three numbers by two single blanks. Terminate the output for the scenario with a blank line.

 

Sample Input

2
4
1 0
0 1
-1 0
0 -1
7
5 0
1 3
-2 2
-1 0
0 -3
-3 1
0 -3

Sample Output

Scenario #1:
0 4 1.0

Scenario #2:
12 16 19.0 

 题目大意:给你n个机器人走的点的坐标,问你在这个范围内有多少点在范围内,有多少点在范围上

思路:题意很简单,但是容易出错啊(PS读错题意,wa了一下午),他给的点是以第一个点为起始,然后对于他的点,也就是说你还要对每个点进行处理,然后再用pick定理进行计算,最后提交用C++交即可

代码: 

/*
题目大意:给你一个三角形,问你三角形内部有多个点
思路:pick定理
*/
#include<set>
#include<map>
#include<ctime>
#include<stack>
#include<queue>
#include<cmath>
#include<string>
#include<vector>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<iostream>
#include<algorithm>
using namespace std;
typedef long long ll;
#define inf 0x3f3f3f
#define bug  printf("bug\n")
const int maxn=1e6+10;
const double pi=acos(-1.0);
const double esp=1e-6;
const int N=2e2+10;
struct point
{
    double x,y;
} p[maxn];
struct line
{
    double k,b;
    point st,ed;
};
double dis(point a,point b)
{
    return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}
double cmult(point a,point b,point c)
{
    return (c.x-a.x)*(b.y-a.y)-(b.x-a.x)*(c.y-a.y);
}
int Stack[maxn],top;
bool cmp(point a,point b)
{
    int ju=cmult(p[0],a,b);
    if(ju>0)
        return 1;
    else if(ju==0&&dis(a,p[0])<dis(b,p[0]))
        return 1;
    return 0;
}
void tb(int n)
{
    point p0;
    int k=0;
    p0=p[0];
    for(int i=1; i<n; i++)
    {
        if(p0.y>p[i].y||(p0.y==p[i].y&&p0.x==p[i].y))
        {
            p0=p[i];
            k=i;
        }
    }
    swap(p[k],p[0]);
    sort(p+1,p+n,cmp);
    if(n==1)
    {
        top=0;
        Stack[0]=0;
        return;
    }
    if(n==2)
    {
        top=1;
        Stack[0]=0;
        Stack[1]=1;
        return;
    }
    if(n>2)
    {
        top=1;
        for(int i=0; i<2; i++)
            Stack[i]=i;
        for(int i=2; i<n; i++)
        {
            while(top>0&&cmult(p[Stack[top-1]],p[Stack[top]],p[i])<=0)
                top--;
            top++;
            Stack[top]=i;
        }
    }
}
int gcd(int a,int b)
{
    int c;
    while(b)
    {
        c=a%b;
        a=b;
        b=c;
    }
    return a;
}

int main()
{
    int test,q=1;
    scanf("%d",&test);
    while(test--)
    {
        int n;
        scanf("%d",&n);
        int xx,yy;
        p[0].x=0,p[0].y=0;
        for(int i=1; i<=n; i++)
        {
            scanf("%d%d",&xx,&yy);
            p[i].x=p[i-1].x+xx,p[i].y=p[i-1].y+yy;
        }
        ll cnt=0;
        double s=0;
        for(int i=0; i<n; i++)
        {
            cnt+=gcd(abs(p[i].x-p[i+1].x),abs(p[i].y-p[i+1].y));
            s+=cmult(p[0],p[i+1],p[i]);
        }
        s=fabs(s)/2;
        printf("Scenario #%d:\n",q++);
        ll cntin=(int)(s)+1-cnt/2;
        printf("%lld %lld %.1f\n\n",cntin,cnt,s);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值