Eddy's research II

Eddy's research II

 

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5247    Accepted Submission(s): 1928

 

 

Problem Description

As is known, Ackermann function plays an important role in the sphere of theoretical computer science. However, in the other hand, the dramatic fast increasing pace of the function caused the value of Ackermann function hard to calcuate.

Ackermann function can be defined recursively as follows:


Now Eddy Gives you two numbers: m and n, your task is to compute the value of A(m,n) .This is so easy problem,If you slove this problem,you will receive a prize(Eddy will invite you to hdu restaurant to have supper).

 

 

Input

Each line of the input will have two integers, namely m, n, where 0 < m < =3.
Note that when m<3, n can be any integer less than 1000000, while m=3, the value of n is restricted within 24. 
Input is terminated by end of file.

 

 

Output

For each value of m,n, print out the value of A(m,n).

 

 

Sample Input

 

1 3 2 4

 

 

Sample Output

 

5 11

 

 

Author

eddy

 

 

Recommend

JGShining

思路:就是找规律,很简单

代码:

#include<stack>
#include<queue>
#include<math.h>
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define max(a,b)a>b?a:b
#define min(a,b)a>b?b:a
int dp[1010][1010]={0};

int f(int x,int y)
{
    int i,j;
    if(x==0)
    {
        return y+1;
    }
    if(x==1)
    {
        return 2+y;
    }
    if(x==2)
        return 3+2*y;
    if(x==3)
    {
        if(y>0)
            return f(2,f(x,y-1));
        if(y==0)
            return f(2,1);
    }
}
int main()
{
   int m,n;
    while(scanf("%d%d",&m,&n)!=EOF)
    {
        int ans=0;
        ans=f(m,n);
        printf("%d\n",ans);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值