WERTYU

                                                         WERTYU
       Time Limit:3000MS    Memory Limit:0KB    64bit IO Format:%lld & %llu

Description


A common typing error is to place the hands on the keyboard one row to the right of the correct position. So "Q" is typed as "W" and "J" is typed as "K" and so on. You are to decode a message typed in this manner.

Input consists of several lines of text. Each line may contain digits, spaces, upper case letters (except Q, A, Z), or punctuation shown above [except back-quote (`)]. Keys labelled with words [Tab, BackSp, Control, etc.] are not represented in the input. You are to replace each letter or punction symbol by the one immediately to its left on the QWERTY keyboard shown above. Spaces in the input should be echoed in the output.


Sample Input

O S, GOMR YPFSU/


Sample Output

I AM FINE TODAY.

题目的大致意思:根据字母在键盘的位置,将输入的字母在键盘上左面的一个字母输出。


可以用一个字符数组存放键盘上的所有字母,值得注意的是:键盘上字母是要包括所有的标点符号和数字的(因为这个小点我WA了好多次);


代码:

#include<stdio.h>
#include<string.h>

int main()
{
    char a[1000];
    int i, j;
    char s[50]={'1','2', '3', '4', '5', '6', '7', '8', '9','0', '-', '=', 'Q', 'W', 'E', 'R', 'T', 'Y', 'U', 'I', 'O', 'P','[', ']', '\\', 'A', 'S', 'D', 'F', 'G', 'H', 'J', 'K', 'L', ';','\'','Z',  'X', 'C', 'V', 'B', 'N', 'M', ',', '.', '/'};
    while(gets(a))
    {
        for(j=0; j<strlen(a); j++)
        {
          if(a[j]==' ')
            printf("%c", a[j]);
        else
            for(i=0; i<46; i++)
            {
                if(a[j]==s[i])
                    printf("%c", s[i-1]);
            }
        }
        printf("\n");
    }
    return 0;
}







  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值