Palindromes


                                                        Palindromes
Time Limit:3000MS    Memory Limit:0KB    64bit IO Format:%lld & %llu

Description

A regular palindrome is a string of numbers or letters that is the same forward as backward. For example, the string "ABCDEDCBA" is a palindrome because it is the same when the string is read from left to right as when the string is read from right to left.

 


A mirrored string is a string for which when each of the elements of the string is changed to its reverse (if it has a reverse) and the string is read backwards the result is the same as the original string. For example, the string "3AIAE" is a mirrored string because "A" and "I" are their own reverses, and "3" and "E" are each others' reverses.


A mirrored palindrome is a string that meets the criteria of a regular palindrome and the criteria of a mirrored string. The string "ATOYOTA" is a mirrored palindrome because if the string is read backwards, the string is the same as the original and because if each of the characters is replaced by its reverse and the result is read backwards, the result is the same as the original string.

Of course,"A","T", "O", and "Y" are all their own reverses.

A list of all valid characters and their reverses is as follows.

CharacterReverseCharacterReverseCharacterReverse
AAMMYY
B
N
Z5
C
OO11
D
P
2S
E3Q
3E
F
R
4
G
S25Z
HHTT6
IIUU7
JLVV88
K
WW9
LJXX


Note that O (zero) and 0 (the letter) are considered the same character and therefore ONLY the letter "0" is a valid character.

Input

Input consists of strings (one per line) each of which will consist of one to twenty valid characters. There will be no invalid characters in any of the strings. Your program should read to the end of file.

Output

For each input string, you should print the string starting in column 1 immediately followed by exactly one of the following strings.

STRINGCRITERIA
" -- is not a palindrome."if the string is not a palindrome and is not a mirrored string
" -- is a regular palindrome."if the string is a palindrome and is not a mirrored string
" -- is a mirrored string."if the string is not a palindrome and is a mirrored string
" -- is a mirrored palindrome."if the string is a palindrome and is a mirrored string

Note that the output line is to include the -'s and spacing exactly as shown in the table above and demonstrated in the Sample Output below.

In addition, after each output line, you must print an empty line.

Sample Input

NOTAPALINDROME 
ISAPALINILAPASI 
2A3MEAS 
ATOYOTA

Sample Output

NOTAPALINDROME -- is not a palindrome.
 
ISAPALINILAPASI -- is a regular palindrome.
 
2A3MEAS -- is a mirrored string.
 
ATOYOTA -- is a mirrored palindrome.

Hint

use the C++'s class of string will be convenient, but not a must



题目的大致意思:判断回文数和镜像数

                            回文数:从左读从右读都是一样的;

                            镜像数:根据给出表格,如果那个字母有镜像数,那么它转换后,从左读从右读都是一样的:

                            注意:字母O和数字0是等价的。

下面是我的代码:

#include<stdio.h>
#include<string.h>

int len;

int Palindromes(char a[])
{
    int i;
    for(i=0; i<len/2; i++)
    {
        <span style="color:#009900;">//O和0是一样的</span>
         if(a[i]=='O'||a[i]=='0')
         {
             if(a[len-1-i]!='0'&&a[len-1-i]!='O')
                return 0;
         }
          else  if(a[i]!=a[len-i-1])
            return 0;
    }
    return 1;
}
int jingxiang(char b[])
{
    int i, j, k;
   char c1[] = {'A',' ',' ',' ','3',' ',' ','H', 'I','L',' ','J','M',' ','O',' ',' ',' ','2','T','U','V','W','X','Y','5'},
        c2[] = {'1','S','E',' ','Z',' ',' ','8',' '},
        temp[21];
        for(i=0, j=len-1; i<len; i++, j--)
        {
            if(b[i]>='A'&&b[i]<='Z')
            {
                k=b[i]-'A';
                temp[i]=c1[k];
            }
            else
            {
                k=b[i]-'1';
                temp[i]=c2[k];
            }
            <span style="color:#009900;">//O和0是一样的</span>
            if((b[i]=='0'&&b[j]=='O')||(b[i]=='O'&&b[j]=='0'))
                continue;
            if(temp[i]!=b[j])
                return 0;
        }
        return 1;

}
int main()
{
    char s[10000];
    int k1, k2;
    while(gets(s))
    {
        k1 = 0, k2 = 0;
        len=strlen(s);
        <span style="color:#33CC00;">//判断回文数</span>
        k1=Palindromes(s);
        <span style="color:#009900;">//判断镜像数</span>
        k2=jingxiang (s);
        if(k1==0&&k2==0)
            printf("%s -- is not a palindrome.\n\n", s);
        if(k1==1&&k2==1)
            printf("%s -- is a mirrored palindrome.\n\n", s);
        if(k1==1&&k2==0)
            printf("%s -- is a regular palindrome.\n\n", s);
        if(k1==0&&k2==1)
            printf("%s -- is a mirrored string.\n\n", s);

    }

    return 0;
}









  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值