hdu 3635 Dragon Balls

Dragon Balls

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5164    Accepted Submission(s): 1936

Problem Description
Five hundred years later, the number of dragon balls will increase unexpectedly, so it's too difficult for Monkey King(WuKong) to gather all of the dragon balls together. 

His country has N cities and there are exactly N dragon balls in the world. At first, for the ith dragon ball, the sacred dragon will puts it in the ith city. Through long years, some cities' dragon ball(s) would be transported to other cities. To save physical strength WuKong plans to take Flying Nimbus Cloud, a magical flying cloud to gather dragon balls. 

Every time WuKong will collect the information of one dragon ball, he will ask you the information of that ball. You must tell him which city the ball is located and how many dragon balls are there in that city, you also need to tell him how many times the ball has been transported so far.


Input
The first line of the input is a single positive integer T(0 < T <= 100). 
For each case, the first line contains two integers: N and Q (2 < N <= 10000 , 2 < Q <= 10000).
Each of the following Q lines contains either a fact or a question as the follow format:
  T A B : All the dragon balls which are in the same city with A have been transported to the city the Bth ball in. You can assume that the two cities are different.
  Q A : WuKong want to know X (the id of the city Ath ball is in), Y (the count of balls in Xth city) and Z (the tranporting times of the Ath ball). (1 <= A, B <= N)
 
Output
For each test case, output the test case number formated as sample output. Then for each query, output a line with three integers X Y Z saparated by a blank space.

Sample Input
2
3 3
T 1 2
T 3 2
Q 2
3 4
T 1 2
Q 1
T 1 3
Q 1
 
Sample Output
Case 1:
2 3 0
Case 2:
2 2 1
3 3 2
 
Author
possessor WC
 
Source

2010 ACM-ICPC Multi-University Training Contest(19)——Host by HDU


重点看变色哪一行。。。它只说city 不同,又没说城市不能反复进出,,如果city可以反复进出了,用代码1就会死循环,,然后用代码2就一直超时,,最后用代码1就直接过来,也是很无语,,,难道进过的城市就不会进了吗???

求解答,,求解答。。。。

懂了,,A所在的城市的龙珠不会回到它们曾去过的地方,因为他们曾经去过的地方现在没有龙珠,龙珠B就不可能在那样的地方,所以并查集不会死循环。。。代码1就可以用了,代码2会超时。。。



代码1:

#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
int shu[10010];
int fer[10010];
int s[10010],fa,fb;
int find(int xx)
{
	int tt=xx;
	while (xx!=fer[xx])
	shu[tt]++,xx=fer[xx];
	return xx;
}
int main()
{
	int t;scanf("%d",&t);
	for (int ca=1;ca<=t;ca++)
	{
		int n,m;
		char ch[2];
		scanf("%d%d",&n,&m);
		memset(shu,0,sizeof(shu));
		//memset(s,1,sizeof(s));
		for (int i=1;i<=n;i++)
		s[i]=1,fer[i]=i;
		printf("Case %d:\n",ca);
		while (m--)
		{
			scanf("%s",ch);
			if (ch[0]=='T')
			{
				int a,b;
				scanf("%d%d",&a,&b);
				fa=find(a);
				fb=find(b);
				fer[fa]=fb;
				/*for (int i=1;i<=n;i++)
				if (fer[i]==fa)
				{
					shu[i]++;
					fer[i]=fb;
					
				}*///printf(" %d  %d  %d\n",s[fa],s[fb],s[3]);
				s[fb]+=s[fa];
				s[fa]=0;
				
			}
			else
			{
				int a;
				scanf("%d",&a);
				shu[a]=0;
				fa=find(a);
				printf("%d %d %d\n",fa,s[fa],shu[a]); 
			}
		}
	}
	return 0;
}



代码2:

#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
int shu[10010];
int fer[10010];
int s[10010],fa,fb;
/*int find(int xx)
{
    while (xx!=fer[xx])
    xx=fer[xx];
    return xx;
}*/
int main()
{
    int t;scanf("%d",&t);
    for (int ca=1;ca<=t;ca++)
    {
        int n,m;
        char ch[2];
        scanf("%d%d",&n,&m);
        memset(shu,0,sizeof(shu));
        //memset(s,1,sizeof(s));
        for (int i=1;i<=n;i++)
        s[i]=1,fer[i]=i;
        printf("Case %d:\n",ca);
        while (m--)
        {
            scanf("%s",ch);
            if (ch[0]=='T')
            {
                int a,b;
                scanf("%d%d",&a,&b);
                fa=fer[a];
                fb=fer[b];
                for (int i=1;i<=n;i++)
                if (fer[i]==fa)
                {
                    shu[i]++;
                    fer[i]=fb;
                    
                }//printf(" %d  %d  %d\n",s[fa],s[fb],s[3]);
                s[fb]+=s[fa];
                s[fa]=0;
                
            }
            else
            {
                int a;
                scanf("%d",&a);
                printf("%d %d %d\n",fer[a],s[fer[a]],shu[a]); 
            }
        }
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值