light oj 1076 - Get the Containers

K - Get the Containers
Time Limit:2000MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu
Submit
 
Status
 
Practice
 
LightOJ 1076
Description
A conveyor belt has a number of vessels of different capacities each filled to brim with milk. The milk from conveyor belt is to be filled into 'm' containers. The constraints are:

1.      Whenever milk from a vessel is poured into a container, the milk in the vessel must be completely poured into that container only. That is milk from same vessel cannot be poured into different containers.
2.      The milk from the vessel must be poured into the container in order which they appear in the conveyor belt. That is, you cannot randomly pick up a vessel from the conveyor belt and fill the container.
3.      The ith container must be filled with milk only from those vessels that appear earlier to those that fill jth container, for all i < j.

Given the number of containers m, you have to fill the containers with milk from all the vessels, without leaving any milk in the vessel. The containers need not necessarily have same capacity. You are given the liberty to assign any possible capacities to them. Your job is to find out the minimal possible capacity of the container which has maximal capacity.

Input
Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case contains two integers n (1 ≤ n ≤ 1000), the number of vessels in the conveyor belt and then m (1 ≤ m ≤ 106), which specifies the number of containers to which you have to transfer the milk. The next line contains the capacity c (1 ≤ c ≤ 106) of each vessel in order which they appear in the conveyor belt. Note that, milk is filled to the brim of any vessel. So the capacity of the vessel is equal to the amount of milk in it.

Output
For each case, print the case number and the desired result. See the samples for exact formatting.

Sample Input
2
5 3
1 2 3 4 5
3 2
4 78 9
Sample Output
Case 1: 6

Case 2: 82


二分比较,,,,,


代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int n,m,shu[1050];
int zhao(int xx)
{
	bool fafe=true;
	int s=0,ge=1;
	for (int i=1;i<=n;i++)
	{
		if (s+shu[i]>xx){
			ge++;
			s=shu[i];
		}
		else
		s+=shu[i];
	}
	if (ge<=m) return true;
	else return false;
}
int main()
{
	int t;scanf("%d",&t);
	for (int ca=1;ca<=t;ca++)
	{
		scanf("%d%d",&n,&m);
		int le=0,mid,ri=0,ans;
		for (int i=1;i<=n;i++)
		{
			scanf("%d",&shu[i]);
			le=max(le,shu[i]);
			ri+=shu[i];
		}
		while (ri>=le)
		{
			mid=(ri+le)/2;
			if (zhao(mid))
			{
				ans=mid;
				ri=mid-1;
			}
			else
			{
				le=mid+1;
			}
		}
		printf("Case %d: %d\n",ca,ans);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值