hdoj 1695 GCD <用容斥求区间素数对>

20 篇文章 0 订阅
7 篇文章 0 订阅

GCD

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 9516    Accepted Submission(s): 3542


Problem Description
Given 5 integers: a, b, c, d, k, you're to find x in a...b, y in c...d that GCD(x, y) = k. GCD(x, y) means the greatest common divisor of x and y. Since the number of choices may be very large, you're only required to output the total number of different number pairs.
Please notice that, (x=5, y=7) and (x=7, y=5) are considered to be the same.

Yoiu can assume that a = c = 1 in all test cases.
 

Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 3,000 cases.
Each case contains five integers: a, b, c, d, k, 0 < a <= b <= 100,000, 0 < c <= d <= 100,000, 0 <= k <= 100,000, as described above.
 

Output
For each test case, print the number of choices. Use the format in the example.
 

Sample Input
  
  
2 1 3 1 5 1 1 11014 1 14409 9
 

Sample Output
  
  
Case 1: 9 Case 2: 736427
Hint
For the first sample input, all the 9 pairs of numbers are (1, 1), (1, 2), (1, 3), (1, 4), (1, 5), (2, 3), (2, 5), (3, 4), (3, 5).
 

Source


学会了怎么求(1-a)与(1,b)区间的素数对;

再根据容斥可求任意两区间的素数对


代码:

#include<cstdio>
#include<cmath>
#include<cstring>
long long  ou[100100];
int su[50],kp;
void  qiu(int xx)
{
    kp=0;
    for (int i=2;i<=sqrt(xx);i++)
    {
        if (xx%i==0)
            su[kp++]=i;
        while (xx%i==0)
            xx/=i;
    }
    if (xx>1)
        su[kp++]=xx;
}
int pp(int n,int k)
{
    qiu(k);
    int qu[5000],ge=0;
    qu[ge++]=-1;
    for (int i=0;i<kp;i++)
    {
        int nn=ge;
        for (int j=0;j<nn;j++)
            qu[ge++]=qu[j]*su[i]*(-1);
    }
    int s=0;
    for (int i=1;i<ge;i++)
        s+=n/qu[i];
    return s;
}
long long  ji(int aa,int bb)
{
    long long  c;
    if (aa>bb)
    {
        c=aa;aa=bb;bb=c;
    }
    if (aa<1)
        return 0;
    c=ou[aa];
    for (int i=aa+1;i<=bb;i++)
    {
        c+=aa-pp(aa,i);
    }
    return c;
}
void  oula()
{
    long long i,j;
    memset(ou,0,sizeof(ou));
    ou[1]=1;
    for (i=2;i<100100;i++)
    {
        if (!ou[i])
        {
            for (j=i;j<100100;j+=i)
            {
                if (!ou[j])
                    ou[j]=j;
                ou[j]=ou[j]-ou[j]/i;
            }
        }
        ou[i]+=ou[i-1];
    }
}
int main()
{
    int t,a,b,c,d,k;
    oula();
    scanf("%d",&t);
    for (int ca=1;ca<=t;ca++)
    {
        scanf("%d%d%d%d%d",&a,&b,&c,&d,&k);
        if (k==0)
        {
            printf("Case %d: 0\n",ca);
            continue;
        }
        a/=k;b/=k;c/=k;d/=k;
       // printf("Case %d: %lld\n",ca,ji(b,d));
       printf("Case %d: %lld\n",ca,ji(b,d)+ji(a-1,c-1)-ji(a-1,d)-ji(b,c-1));
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值