UVA253 - Cube painting

WA的原因竟然因为....竟然因为...把TRUE拼成TURE了...英死早,囧...

题目:

Cube painting

 

 Cube painting 

We have a machine for painting cubes. It is supplied with three different colors: blue, red and green. Each face of the cube gets one of these colors. The cube's faces are numbered as in Figure 1.

 

picture21

 

 

Figure 1.

Since a cube has 6 faces, our machine can paint a face-numbered cube in tex2html_wrap_inline126 different ways. When ignoring the face-numbers, the number of different paintings is much less, because a cube can be rotated. See example below. We denote a painted cube by a string of 6 characters, where each character is a b, r, or g. The tex2html_wrap_inline128 character ( tex2html_wrap_inline130 ) from the left gives the color of face i. For example, Figure 2 is a picture of rbgggr and Figure 3 corresponds to rggbgr. Notice that both cubes are painted in the same way: by rotating it around the vertical axis by 90 tex2html_wrap_inline134 , the one changes into the other.

tex2html_wrap138 tex2html_wrap140

Input

The input of your program is a textfile that ends with the standard end-of-file marker. Each line is a string of 12 characters. The first 6 characters of this string are the representation of a painted cube, the remaining 6 characters give you the representation of another cube. Your program determines whether these two cubes are painted in the same way, that is, whether by any combination of rotations one can be turned into the other. (Reflections are not allowed.)

 

Output

The output is a file of boolean. For each line of input, output contains TRUE if the second half can be obtained from the first half by rotation as describes above, FALSE otherwise.

 

Sample Input

 

rbgggrrggbgr
rrrbbbrrbbbr
rbgrbgrrrrrg

 

Sample Output

 

TRUE
FALSE
FALSE

解答:

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
int rot[6][6]={{1,2,3,4,5,6},{2,6,3,4,1,5},{6,5,3,4,2,1},{5,1,3,4,6,2},{3,1,2,5,6,4},{4,6,2,5,1,3}};
char str[20],s1[10],s2[10],tmp[10];
int main()
{
	while(gets(str)!=NULL)
	{
		int i,j,p,flag=0;
		for(i=0;i<6;i++)
			s1[i]=str[i];
		s1[i]='\0';
		for(j=0,i=6;i<strlen(str);i++,j++)
			s2[j]=str[i];
		s2[j]='\0';
		for(i=0;i<6;i++)
		{
			p=0;
			for(j=0;j<6;j++)
			{
				tmp[p]=s1[rot[i][j]-1];
				p++;
			}
			tmp[p]='\0';
			char tt;
			for(j=0;j<4;j++)
			{
				tt=tmp[1];
				tmp[1]=tmp[2];
				tmp[2]=tmp[4];
				tmp[4]=tmp[3];
				tmp[3]=tt;
				if(strcmp(s2,tmp)==0)
				{
					flag=1;
					break;
				}
			}
		}
		if(flag)
			printf("TRUE\n");
		else
			printf("FALSE\n");
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值