Ananagrams uva156

 Ananagrams 

Most crossword puzzle fans are used to anagrams--groups of words with the same letters in different orders--for example OPTS, SPOT, STOP, POTS and POST. Some words however do not have this attribute, no matter how you rearrange their letters, you cannot form another word. Such words are called ananagrams, an example is QUIZ.

Obviously such definitions depend on the domain within which we are working; you might think that ATHENE is an ananagram, whereas any chemist would quickly produce ETHANE. One possible domain would be the entire English language, but this could lead to some problems. One could restrict the domain to, say, Music, in which case SCALE becomes a relative ananagram (LACES is not in the same domain) but NOTE is not since it can produce TONE.

Write a program that will read in the dictionary of a restricted domain and determine the relative ananagrams. Note that single letter words are, ipso facto, relative ananagrams since they cannot be ``rearranged'' at all. The dictionary will contain no more than 1000 words.

Input

Input will consist of a series of lines. No line will be more than 80 characters long, but may contain any number of words. Words consist of up to 20 upper and/or lower case letters, and will not be broken across lines. Spaces may appear freely around words, and at least one space separates multiple words on the same line. Note that words that contain the same letters but of differing case are considered to be anagrams of each other, thus tIeD and EdiT are anagrams. The file will be terminated by a line consisting of a single #.

Output

Output will consist of a series of lines. Each line will consist of a single word that is a relative ananagram in the input dictionary. Words must be output in lexicographic (case-sensitive) order. There will always be at least one relative ananagram.

Sample input

ladder came tape soon leader acme RIDE lone Dreis peat
 ScAlE orb  eye  Rides dealer  NotE derail LaCeS  drIed
noel dire Disk mace Rob dries
#

Sample output

Disk
NotE
derail
drIed
eye
ladder
soon

(白书第五章P78)

题意:输入一个字典(用‘#’结尾),找出字典中不重复的单词(重复的单词:字母顺序可以不同,不区分大小写),并按照字典序从小到大的顺序输出。

思路:(1)首先需要把字典读入并保存下来,将其按字典序排列

(2)将字典逐个保存到另一个数组中,大写转化成小写,并将单词中的各个字母排序

(如何判断单词重不重复:把单词中的大写字母转化成小写,再把各个字母排序,然后直接比较即可)

#include<stdio.h>
#include<stdlib.h>
#include<string.h>

int cmp_char(const void *_a,const void * _b)    //字符比较函数
{
    char* a=(char*)_a;
    char* b=(char*)_b;
    return *a-*b;
}
int cmp_string(const void* _a,const void* _b)   //字符串比较函数
{
    char *a = (char*)_a;
    char *b = (char*)_b;
    return strcmp(a,b);
}
int main()
{
    int i,j;
    int n;
    char word[2000][90],sorted[2000][90];
    n=0;
    for(;;)
    {
        scanf("%s",word[n]);
        if(word[n][0]=='#')break;
        n++;
    }
    qsort(word,n,sizeof(word[0]),cmp_string);   //给所有单词排序
    for(i=0; i<n; i++)
    {
        for(j=0; j<strlen(word[i]); j++)
        {
            if(word[i][j]>='A'&&word[i][j]<='Z')
                sorted[i][j]=word[i][j]+32;     //将大写字母转化成小写字母
            else sorted[i][j]=word[i][j];

        }
        qsort(sorted[i],strlen(sorted[i]),sizeof(char),cmp_char);    //给每个单词排序
    }
    for(i=0 ; i<n ; i++)
    {
        int found = 0;
        for(j=0; j<n; j++)
        {
            if(strcmp(sorted[i],sorted[j])==0&&i!=j)
            {
                found=1;
                break;
            }
        }
        if(found==0)
            printf("%s\n",word[i]);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值