hdu1711 Number Sequence

Problem Description
Given two sequences of numbers : a[1], a[2], … , a[N], and b[1], b[2], … , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], … , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.

Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], … , a[N]. The third line contains M integers which indicate b[1], b[2], … , b[M]. All integers are in the range of [-1000000, 1000000].

Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.

Sample Input
2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1

Sample Output
6
-1

KMP算法在大一下学数据结构的时候就已经了解,现在终于自己手写代码完成(当然借鉴数据结构书里面的kmp算法)(๑‾ ꇴ ‾๑)嘻嘻嘻。下面的代码比较简单易懂,适合初学者(毕竟自己就是小白,怎么会写出高深的代码,o(╥﹏╥)o)

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
#define N 1000005
using namespace std;
int a[1000005];
int b[10005];
typedef struct{
	int ch[N];
	int length; 
}SString;
int m,n;
SString s1,s2;
int nextval[10005];
void get_next(SString T)//求next函数的值 
{
	int i=1,j=0;
	nextval[1]=0;
	while(i<T.length)
	{
		if(j==0||T.ch[i]==T.ch[j])
		{
			++i,++j,nextval[i]=j;
		}
		else
		j=nextval[j];
	}	
}
int Index_KMP(SString S,SString T,int pos)
{
	int i=pos,j=1;
	while(i<=S.length&&j<=T.length)
	{
		if(j==0||S.ch[i]==T.ch[j])
		{
			++i,++j;
		}
		else
		j=nextval[j];
	}
	if(j>T.length)
	return i-T.length;
	else
	return -1;
}
int main()
{
    int o,m,n;	
    scanf("%d",&o);
    while(o--)
    {
    	scanf("%d %d",&m,&n);
    	for(int i=1;i<=m;i++)
    	scanf("%d",&s1.ch[i]);
    	s1.length=m;
    	for(int i=1;i<=n;i++)
    	scanf("%d",&s2.ch[i]);
    	s2.length=n;
    	get_next(s2);
    	printf("%d\n",Index_KMP(s1,s2,1));   	
	}
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值