HDU-1005-Number Sequence

点击打开链接




Number Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 177757    Accepted Submission(s): 44122


Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 

Output
For each test case, print the value of f(n) on a single line.
 

Sample Input
      
      
1 1 3 1 2 10 0 0 0
 

Sample Output
      
      
2 5

题解:这道题可以用矩阵来做,当然如果找规律也可以,用到了矩阵的快速幂,如果理解,对于很多题都有好处

通过观察可以看到这样一个关系,这样就能把这道题转化为矩阵快速幂了
矩阵递推式

#include<stdio.h>
#include<cstring>
using namespace std;
const int mod=7;
struct Matrix{		//用结构体比较好理解,如果对指针很熟练,用指针做形参也行
	int f[2][2];
}mat;
Matrix Mul(Matrix a,Matrix b,int mod)	//矩阵相乘 
{
	Matrix res;
	memset(res.f,0,sizeof(res.f));
	for(int i=0;i<2;i++)
		for(int j=0;j<2;j++)
			for(int k=0;k<2;k++)
		res.f[i][j]=(res.f[i][j]+(a.f[i][k]%mod)*(b.f[k][j]%mod))%mod; 
	return res;		
}
Matrix FastPower(Matrix mat,int k,int mod)	//矩阵快速幂,与整数的快速幂思路一样
{
	Matrix t;
	memset(t.f,0,sizeof(t.f));	//清零
	for(int i=0;i<2;i++)
		t.f[i][i]=1;
	while(k)
	{
		if(k&1)	//如果k时奇数时,先让t乘一个,这样剩下的就是偶数个了
			t=Mul(t,mat,mod);	//t与任何矩阵相乘原矩阵都不变,还是mat
		k/=2;
		mat=Mul(mat,mat,mod);	 
	}
	return t;
}
int main()
{
	int a,b,n;
	while(~scanf("%d%d%d",&a,&b,&n))
	{
		if(a==0&&b==0&&n==0)
			break;
		if(n==1||n==2)
			printf("1\n");
		else	
		{				//赋初值
			mat.f[0][0]=a;	
			mat.f[0][1]=b;
			mat.f[1][0]=1;
			mat.f[1][1]=0;
			Matrix ans=FastPower(mat,n-2,mod);
			printf("%d\n",(ans.f[0][1]+ans.f[0][0])%mod);
		}
	}
	return 0;
}


Number Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 177757    Accepted Submission(s): 44122


Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 

Output
For each test case, print the value of f(n) on a single line.
 

Sample Input
       
       
1 1 3 1 2 10 0 0 0
 

Sample Output
       
       
2 5
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值