Red and Black
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13414 Accepted Submission(s): 8306
Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can’t move on red tiles, he can move only on black tiles.
Write a program to count the number of black tiles which he can reach by repeating the moves described above.
Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.
There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.
‘.’ - a black tile
‘#’ - a red tile
‘@’ - a man on a black tile(appears exactly once in a data set)
Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
Sample Input
6 9
….#.
…..#
……
……
……
……
……
@…
.#..#.
11 9
.#………
.#.#######.
.#.#…..#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#…….#.
.#########.
………..
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
.
…@…
.
..#.#..
..#.#..
0 0
Sample Output
45
59
6
13
分析:此题已经用dfs做过一遍,现在用bfs实现,采用queue的用来存储下一轮需要被搜索的点
//try using bfs search connecting blocks.
#include"iostream"
#include"cstdio"
#include"queue"
#include"cstdlib"
#include"cstring"
using namespace std;
int n,m;
int dis[4][2]={{0,1},{1,0},{-1,0},{0,-1}};
int sx,sy;
char map[25][25];
int vis[25][25];
int bfs(int c,int r,int sum){
int xx,yy;
queue<int>w;
queue<int>h;
h.push(c);
w.push(r);
while(!h.empty()){
c=h.front();
r=w.front();
h.pop();
w.pop();
for(int i=0;i<4;i++){
xx=c+dis[i][0];
yy=r+dis[i][1];
if(xx>=0&&yy>=0&&xx<n&&yy<m&&vis[xx][yy]==0&&map[xx][yy]=='.'){
sum++;
h.push(xx);
w.push(yy);
vis[xx][yy]=1;
}
}
}
return sum;
}
int main(){
int f;
while(scanf("%d %d",&m,&n)==2&&n&&m){
f=0;
memset(map,0,sizeof(map));
memset(vis,0,sizeof(vis));
for(int i=0;i<n;i++){
scanf("%s",map[i]);
if(f==0){//avoid some needless search
for(int j=0;j<m;j++)
if(map[i][j]=='@'){
map[i][j]='.';
vis[i][j]=1;
sx=i;//record begin position
sy=j;
f=1;
}
}
}
//cout<<sx<<" "<<sy<<endl;
int num=bfs(sx,sy,1);
cout<<num<<endl;
}
}