HDU1054 Strategic Game 树形DP


这种类型的题目,每个节点有两个不同的状态,分别是存在和不存在士兵,分别求出不同状态的最小消耗就可以了。

1:以当前节点为根节点,在该节点排士兵守护道路的最小消耗。在这种情况下,他的子节点可以安排士兵,也可以不安排士兵。可以从各个子节点两个不同状态(存在士兵,不存在士兵)的最值中选出最小的消耗,然后相加就求出了当前节点派士兵的最小消耗。

2:以当前节点为根节点,不存在士兵。这种情况十分清楚,因为当前节点没有士兵,那么这个节点到子节点之间的道路没有人守护,那么子节点就必须要安排士兵,因此这种情况下。这个节点的最小消耗就是每个子节点存在士兵的情况下的最小消耗的和。

Strategic Game

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2736    Accepted Submission(s): 1134


Problem Description
Bob enjoys playing computer games, especially strategic games, but sometimes he cannot find the solution fast enough and then he is very sad. Now he has the following problem. He must defend a medieval city, the roads of which form a tree. He has to put the minimum number of soldiers on the nodes so that they can observe all the edges. Can you help him?

Your program should find the minimum number of soldiers that Bob has to put for a given tree.

The input file contains several data sets in text format. Each data set represents a tree with the following description:

the number of nodes
the description of each node in the following format
node_identifier:(number_of_roads) node_identifier1 node_identifier2 ... node_identifier
or
node_identifier:(0)

The node identifiers are integer numbers between 0 and n-1, for n nodes (0 < n <= 1500). Every edge appears only once in the input data.

For example for the tree:



the solution is one soldier ( at the node 1).

The output should be printed on the standard output. For each given input data set, print one integer number in a single line that gives the result (the minimum number of soldiers). An example is given in the following table:

Sample Input
  
  
4 0:(1) 1 1:(2) 2 3 2:(0) 3:(0) 5 3:(3) 1 4 2 1:(1) 0 2:(0) 0:(0) 4:(0)
Sample Output
  
  
1 2
#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<string>
#include<cstdlib>
#include<vector>
#include<iterator>

using namespace std;

#define MAXN 1510

vector<int> node[MAXN];
bool visited[MAXN];
int dp[2][MAXN];   //dp[0][i] 节点i放士兵的最小消耗方案   dp[1][i] 节点i不放士兵的最小方案 
int n;

int min(int a,int b)
{
	return a<b?a:b;
}

void init()
{
	int root,to;
	char a;
	int num;
	memset(dp,0,sizeof(dp));
	memset(visited,0,sizeof(visited));
	for(int i=0;i<=n;i++)
		node[i].clear();
	for(int i=1;i<=n;i++)
	{
		cin>>root>>a>>a>>num>>a;
		for(int j=0;j<num;j++)
		{
			cin>>to;
			node[root].push_back(to);
			node[to].push_back(root);
		}
	}
}

void dfs(int root)
{
	int temp;
	visited[root]=true;
	for(int i=0;i<node[root].size();i++)
	{
		temp=node[root][i];
		if(visited[temp])
			continue;
		dfs(temp);
		dp[1][root]+=dp[0][temp];
		dp[0][root]+=min(dp[1][temp],dp[0][temp]);		
	}
	dp[0][root]+=1;
}


int main()
{
	while(cin>>n)
	{
		init();
		dfs(0);
		cout<<min(dp[1][0],dp[0][0])<<endl;
	}
	
	return 0;
}

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值